Apple TV 1

I am sitting here watching the WF2IR and the apple TV 1. I can see the WF2IR send the signal, and I can see the Apple TV led blink orange in receipt of the signal, but it does not respond. It is not a remote pairing issue. I have a URC remote right here that I can use IR codes to control the Apple TV. I can also use the remote app on my iOS to control the Apple TV. All work. In addition to that, the Apple TV IR I’m using is a blaster that is also controlling my DVD player. When I send signals to it, it works. So all the hardware is working. I can’t think of anything else to troubleshoot. Quite vexing.

Any remote can be paired including a universal remote, so the existence of a remote that works does not indicate that it’s not a pairing issue. So first we’d recommend checking the pairing and unpairing any existing remotes in the settings on the Apple TV.

If you find that’s not the issue, then it’s probably something very basic like the emitter/blaster:

Can you elaborate a little on the pairing thing because I can’t make sense out of your explanation. The only remotes I have paired to the Apple TV are 2 iphones. I never paired my universal remote to it, that isn’t necessary with IR, I simply programmed the codes to it and it works. That is what I expected with the WF2IR.

I went through the blaster/emitter FAQ and everything is working, and set to blaster on port 3. As I mentioned, the blaster controls my DVD player just fine. Also, the Apple TV is receiving the signal from the blaster, as it blinks orange whenever there is an IR code.

So I’m still a bit confused. Suggestions?

The Apple TV, unlike pretty much any other device in the world, pairs infrared remotes. It’s a bit of sleight of hand. Basically there are 256 sets of potential codes for the Apple TV and the Apple TV can pay attention to only the set produced by a particular remote instead of all 256.

In any case, whether this is the issue you’re having is very simple to check. Go to Settings->General->Remotes on the Apple TV and look for the Pairing options there.

I got it working. But I gotta say, the Apple interface for IR remotes leaves a little to be desired.

First off, I NEVER paired my URC remote. It just worked, so I’m assuming the unit either paired automatically, or the sweet code I got from remote central was money. Also, IR paired remotes do not show up in the list. So I googled it and found that you can manually pair/unpair by holding menu/forward or menu/reverse, respectively. That worked, much to my surprise, without the Apple TV even saying it did. I got a little of the bar filled in the graphic, but it didn’t finish and I never got a confirmation. It just ditched my URC remote and now the Roomie works fine.

I get their reason for pairing IRs, but really? And the interface? Geez.

Now of course I want my roomie remote to have the swipe feature so I guess I’ll go searching to find that, I’m assuming you have it.