AppleTV OS 15 Compatibility?

Leaving this information here for those asking about how to use the new app launch feature we added:

We didn’t have time to make that user-friendly. Basically you need to manually send the command .APP LIST from a test activity. Then open the user-visible log (pinch the screen), scroll up to the list of apps, and record the bundle ID for the app you want to launch. It will be something like or that kind of thing. Then enter that into the parameter for the .APP LAUNCH command.

Do you have a general idea for when the .voice command stuff will be up and running for tvOS 15?

What I can say is that I’m 100% certain that any ATV4 feature from tvOS 14 will be back and more. The current method is somewhat temporary as we restructure things.

@Will_Price I’ve tried using the .APP LIST functionality a number of times and every time the list of apps is truncated in the user-visible log after listing 3 apps. Also, the .APP LAUNCH command doesn’t appear to have a field for me to input the app bundle ID. Am I doing something wrong?

Do a Force Code Set Update and that will fix the .APP LAUNCH.

Force code set fixed the .app launch text input field but when I create a button and assign it .app list, press that button in the activity and go to the logs I don’t even see a list of applications. I have to pause the logs as it continues to scroll and never find any list of apps. Perhaps I’m not doing something correctly??

Has anyone come up with a workaround for the tvos15/Roomie 7 incompatibility that reportedly a few people are experiencing?

I’ve got 4 ATV’s and only one is working correctly. All setup the same. Tried removing the devices and adding them back but I cannot get the screen to appear that’s calls for entering of 4 digits.

I realize there are things still being worked on so this isn’t a support issue. Just looking for any other people that have found a workaround or solution.

There are two issues. 90% of people are experiencing 0 issues. Of those experiencing an issue with tvOS 15, most of the rest have an incorrect Allow Access setting on the Apple TV. Make sure you have the following set exactly as shown or to “Everyone”. For those last few that continue to experience an issue after fixing that, we’re aware of it and [the fix is in 7.0.2 now available].

1 Like


So, I was among those having an issue with IP control after updating my theater room setup to 7/tvOS 15. The setup in my living room had not yet been updated on either end and continued to work. My wife accidently allowed the ATV in the living to install the tvOS 15 update. With that I decided to see if the living room ATV would work in the theater room so I swapped them.

It turned out that it worked. After reading Will’s above post yesterday I checked the settings on the ATV that was now in the living room and sure enough I needed to make the settings referenced in his post. I then updated the controller in the living room to V7 and that solved the issue.

I post this for those that are still having issues and want to encourage you to double check the settings outlined here. I do miss having feedback when streaming from the ATV and look forward to having that back.



Thanks for the update. I also made the setting changes Will referenced on my ATV’s and was hopeful it would also solve my tvOS/Roomie issues, however I must be in the 10% as I still get no response from any of my 3 ATV’s. Hopefully the upcoming update will solve this as I greatly miss the Roomie ATV integration…

Same here. I will be anxiously waiting for it. 3 out of 4 Apple TV’s don’t work and all are setup the same as far as I can see. Using a Eero mesh router system otherwise I can’t figure out what else could be setting my system apart from others.

Add me to the list of AppleTVs not working. Updated 3 ATV to 15 and 2 out of 3 don’t work anymore with Roomie. The ones which don’t work already had access set to everyone. I am afraid to update my other 5 ATVs to 15, can’t afford to lose control.

Not sure if this will be helpful, but I also have one of the 10% problematic AppleTV 4K units that wouldn’t respond in the new Roomie Remote 7.0.1 app. I went to the extreme and deleted the ATV device and did a reset within the Roomie app (make sure you have a good backup). That removed the Primary controller and my Home. When i re-added my Home and set my iPad as the primary device and re-added the ATV, the request for remote pairing immediately showed up. All is working well again. FWIW.

The remaining fix in this area is going live now in version 7.0.2.

Future efforts later this year will focus on restoring secondary features on tvOS 15 like voice control, etc. For now, everyone should have control back as well as direct app launch.

Check the setting above and/or reset your ATV to factory settings if needed.

1 Like

Will, any idea on live feedback returning? I have had it since tvOS 15

Sorry, haven’t had it since upgrading to tvOS 15. Thanks

I already addressed all such questions above. I know it’s a long thread at this point, but please read it all before asking new questions here.

Will and team. I have to say I was a bit irritated with tvOS 15 support UNTIL I read this thread. After understanding what has happened I can only say I am 100% satisfied with paying my subscription to Roomie Remote. Fantastic job getting this up and running in time! All my Apple TVs are working fine. My only issue right now is super low speed scrubbing but I will live with it knowing you guys are probably on the case.

V7.1 is releasing now.

The initial 7.0 release contained a whole new method for ATV control built from scratch. It’s a method called Companion, but does not (currently) support Siri voice, media feedback, or keyboard.
The new 7.1 release contains yet a third method! We had planned from mid-Summer to build this in two stages as we did.

While this method was much more difficult to build requiring far more effort, it was able to take advantage of our many years of ATV control refinements such as gesture support, long presses, Siri voice, and media feedback. For now, keyboard support goes through the system notifications you already get – so you type into control center built into iOS. Not sure yet if it is worth bringing that back into the app, we’ll see how people like it this way.

This was not how we expected to spend 4 months, but it was worthwhile and I’m now pretty happy with ATV control.

1 Like

Thank you Will for all your hard work, just updated and everything seems to be working great!

Is it ok do remove the old pairing codes in Apple TV as I see a new entry for “Unknown Device” ?