How to setup Insteon Lighting with ISY-99

I can’fing any guides on setting up lighting with ISY. Automatic discovery finds ISY-99i on my network. Under Authentification I entered username and password I use to access Administration Console ( I tried with or without credentials) . I tried to enter Insteon switch address under Default Device. Nothing happenning when I try to control light. How I suppose to assign specific lights or scenes to a room?

The Default Device is more of a convenience. You can ignore it for the most part unless you’re trying to create a Virtual Remote for a specific light with feedback.

For most lighting control, you simply add commands either to an Activity or a Button as needed. So for instance you would add a .LIGHT OFF command to your ‘Watch TV’ Activity and the device for that might be ‘1A 1A 1A’. The list of devices from the ISY is also shown right below the device field so you can just select it from there as well.


If you do not see the list of devices/scenes populating in the app then your connectivity to the ISY may not be working (check port, user name, password).

You currently can not control any device what requires a 4th address (each buttons on a keypad link, devices on a fan lamp, etc since they need XX XX XX x and the app only supports XX XX XX)

Also I found I had to strip any leading 0 from the first XX for the app to take it. The olds at Roomie could not see that issue and I can’t explain why (other than maybe it’s fixed in 1.5 and they have it and i don’t yet). But if your device starts with a 0 try dropping it off.

Good luck,

Thank you for your suggestions.
Indeed I can’t see list of Insteon devices. It shows Controller under “Edit Device”. Where would I see the list?
On ISY About page it only shows ISY URL with IP, but no ports. Internet Access says disabled. I assumed on internal network I should have no problems connecting to ISY - I’m not looking for outside access yet. Roomie automatically discoveres the ISY with proper IP. For credentials I use the same as Admin Console username and passwod.
I entered manually address in suggested format under default address and Test works fine. It means Roomie connects to ISY OK. Why would it not show a list?

My bad. I looked in the wrong place. I see the list when creating activities. I was looking under devices. Thank you for all the help and great support