iTach IP/Serial control - diagnostics?

Okay, I’m hoping someone out there can give me some tips. I’ve successfully set up serial control via my previous RC system (URC/MSC-400/MX-800s).

Now I’m trying to get serial control working with Roomie/iTach. I’m having zero luck. I have an Anthem D2v, but that’s sort of immaterial is that’s just the command set (which I know works since I had to set it up by hand before).

When I try to use Roomie with the iTach Serial/IP, nothing works at all. I see the iTach blink a little on the serial port, so I assume something is being sent, but nothing actually happens on the device.

I tried the built-in Anthem device, and I tried creating my own custom device (which I’ve done successfully before with Roomie with IP devices), but nothing works.

Any guidance, or any way to further diagnose? Can I get some diagnostic information from Roomie or the iTach to see what is being sent and received? Is there any way to open up a RAW connection to the iTach to try sending commands manually, so I can start to narrow down where the problem is?

Thanks in advance for any help

For anyone interested, there’s an iTest tool (Mac and PC) that let’s you connect directly with an iTach device and send commands of different types (text, binary, hybrid).

Will be testing tonight to narrow the diagnostics path, will post back what I find out.

So my problem was that the serial port had to be at 115200 N81, and the format had to be lineio. I guess I never had that specific combination.

The iTest tool was very helpful as it allowed me to test just the serial port configuration, so I was focused on just a couple of variables at a time.

Will thoroughly test this weekend and report results of stability and accuracy, and if the buffering works well.

Getting closer to completely replacing what now seems like an archaic URC system! I just have to buy 7 x iPods now to replace my remotes…