OPPO 103 virtual remote Netflix button not functioning

When I press the Netflix button nothing happens but if I press the Vudu button it goes to Netflix. Must be mismapped? Also will Vudu graphic be added to virtual remote?

Are you using serial or IP as the command sets are not related?

Either way, it sounds like a bug on the Oppo side. The underlying commands are effectively “NFX” and “VDU” and they are correctly mapped in Roomie in both sets so the only way to mismap those would be if your box was misinterpreting them. The Remote Design can be used to remap them regardless.

I’m having the exact same issue as OP.

Also, I checked with the Oppo remote app on my iPad and both the Netflix and Vudu buttons functions properly.

Using IP commands

We’re going to look further into this. If anyone with a 103 is using serial and seeing this, please let us know. We assume this is limited to the new IP set for now. The commands are correctly mapped in Roomie, so the only way we can see their app doing this differently would be if they intentionally mismapped the commands to work around a firmware bug in the Oppo. To determine that we need to ask Oppo and/or reverse engineer their app with a 103 as those commands don’t do anything on the 9X models anyway.

I just received teh Itach IP2SL today so I’ll try and hook up the 103 via serial to see if it works correctly.

Okay, finally got around to setting up the Itach IP2SL on the OPPO 103 today and it appears that the commands in the virtual remote for Netflix works correctly. But the VUDU command still doesn’t function it actually appears to be linked to another key.

I have the BDP-103 and via IP control Netflix button does not work from Roomie yet works fine from Oppo’s iOS app. Anything I can do to help debug this one? Also, any workaround on my end to get this to work? Thx!


I havn’t tried the individual button in the Virtual remote but I have a Macro set up to turn the TV on, switch imputs, turn the OPPO 103 on and then switch to NETFLIX and it has worked every time without problem.

asunsell, lucky you :wink: I have worked with Roomie support, and everything we’ve tried has not worked. They acknowledged that this is a problem in that they are following the documentation they got from Oppo but it doesn’t work. I do have the most recent Roomie iOS app and have the up-to-date 103 firmware. Is it possible you are on an older 103 firmware that happens to work? Also, if convenient, can you try the Netflix button on the virtual remote and see if it works, toggling between Netflix and Main menu for example? Appreciate your help!

Still does not work correctly. Vudu is mapped to Netflix, can’t find a way to directly start Vudu on the Oppo.

We’re following Oppo’s vendor documentation and just received an update to that as recently as last month. The codes are still correct according to that, so as per our previous posts here if the Vudu button doesn’t map to the right app, it’s a bug on the Oppo side. Either Oppo needs to fix that, or someone needs to sniff packets on a 103 model to figure out what they mis-mapped the code as.

Thank you.