Serial Control of Sony SXRD projectors


I hope to use Roomie to control my Sony VW60 front projector with RS232. I have the serial codes document and it likely calls for a null modem cable.

Has any work on this started and if not … how do I start?

All I want/need is on/off capability.


I added on-off for my sony VW100. Should be the same code. In this file:

    All Models Serial
        POWER ON\x02 \x00\x00\x00\x00\x00\x0323
        POWER OFF\x02!\x00\x00\x00\x00\x00\x0324

        MENU SETUP\x02E\x00\x00\x00\x00\x00\x0348
        MENU TOP\x02\x46\x00\x00\x00\x00\x00\x0349
        MENU POPUP\x02\x47\x00\x00\x00\x00\x00\x0341

        CURSOR UP\x02\x4D\x32\x00\x00\x00\x00\x0382
        CURSOR DOWN\x02\x4D\x33\x00\x00\x00\x00\x0383
        CURSOR LEFT\x02\x4D\x31\x00\x00\x00\x00\x0381
        CURSOR RIGHT\x02\x4D\x34\x00\x00\x00\x00\x0384
        CURSOR ENTER\x02\x4E\x00\x00\x00\x00\x00\x0351

        OPEN CLOSE\x02\x61\x00\x00\x00\x00\x00\x0364

        POWER ON\xA9\x17\x2E\x00\x00\x00\x3F\x9A
        POWER OFF\xA9\x17\x2F\x00\x00\x00\x3F\x9A

Ok - all the XML disappeared when I posted.

Added this to the plist file:

“POWER ON\xA9\x17\x2E\x00\x00\x00\x3F\x9A”
“POWER OFF\xA9\x17\x2F\x00\x00\x00\x3F\x9A”

Post still won’t work - sorry.

If you’d like to submit codes, just send RoomieCodes files to, we’ll check them against the published specs and include them in the main library. Thanks.

I hesitated to submit the Sony projector codes since I only implemented power on and power off.


Thank YOu Avolfe63. I’m glad to check back and see progess on this point.

I haven’t purchased the needed itach device and have a hard time deciding between the rs232 (which I would prefer but not sure it would work) and the IR which would possibly give me more options for control.

I’ll post the information I have about the rs232 codes…

At any rate… I was glad to see the post didn’t go un-noticed.



I’m reading the rs232 manual and not really understanding it.

It confirms a cossover cable is used.

It shows

Power On 03h
Standby 00h

I have zero experience programming for rs232 but I can learn. On and Off capability is all that I want. I imagine for some input selection (and any number of other controls) would be desired.


If it’s useful (for anyone) the manual for rs232 of sony projectors VW40 and VW60 is online directly from Sony here…

I assume this same protocol would apply to a large array of Sony projectors.


I will buy the serial itach and try the given codes.

(soon … but maybe not like today.)


I can email anyone the control file - this forum just won’t let me post XML.

contact me at

I tried to send email there. I didn’t know and it bounced.

Is it just (nothing here) ?

OK - I don’t understand this forum - it deleted part of my post again - I think because it was in the wrong quotes. I just hate putting my whole email in a post because of harvesters.

email address is awolfe
domain is

Until we can upgrade the forum to support more types of content, feel free to email us a file and we can put it up in the forum.

I will have my serial itach tomorrow and can’t wait to attempt to get it working, I could have gone with ir which is supported so I only have myself to blame if I have difficulties.

I think I have enough info to at least try.

Got Awolfe’s Plist file and I think that’s all I need… I’ll report back when it works.

The command set referenced earlier in this thread was added to the main library. So at least for Power On/Off, you should be able to get it working, but the set doesn’t have a lot of other commands yet.

Ok, thanks.

When I get it working (can’t wait), I’ll see if I can add more commands.

I only need on/off but if I can document more controls I will report back.

Thrilled because it worked.

It’s perfect now but I still can’t wait for 1.5

By reading the RS232 manual and working with the codes I was given for power on and power off… I was able to create codes for all the original remote functions and even some controls that you only get via RS232 like Picture Muting.

It works great … Only think I don’t understand is it seems to need 40 seconds or so between commands. That’s not normal is it?