Alexa Visibility default settings

In RR Alexa settings l have activities checked on for only those that l wish to show up in Alexa as devices in order for me to create Alexa “routines”. To get RR activities as devices in Alexa l figured out that we need to use the old simple control skill.

I love this setup “Alexa Routines + RR activities” absolutely great/fantastic as we can now create custom Alexa commands phrases

Using the RR Alexa skill one has to go via launch RR, it’s a great feature as well, but in my case the former works great.

So far so good…however the issue is as follows :

  • After we do a HomeKit sync all HomeKit devices gets checked on in RR and then they show up in Alexa as new devices
  • l tried to uncheck but I guess they still end up in some buffer somewhere in the cloud and shows up again
  • more so if say we sync RR HomeKit again they all show up again as duplicates
  • This is definitely Alexa issue

However if a simple default setting in RR would go long ways…that is by default if all devices are left “unchecked”

Same for activities if we create a new activity in RR by default it’s checked on in Alexa Visibility, if the default setting for all new activities and devices and rooms is set to unchecked it will be “fantastic”