Apple TV - Paired Remote

I’m relatively new to Roomie, but I believe I’ve tried everything possible and am stumped. I purchased to IR2IP devices, one for a bedroom and another for my living room. I have two “Rooms” setup in Roomie accordingly.

For background information, in the bedroom, I have an Apple TV (v3 - 1080p) that is being controlled via one of the individual IR transmitters (not IR blaster). I also have a Samsung DVD player and TV on the other ports, all configured as individual IR transmitters. I have Roomie controlling a TIVO HD as well. All of this works beautifully with one exception: the Apple TV (v3 - 1080p) works great with the Virtual Remote but choosing the Apple TV remote does not allow the Play/Pause button to work (directional/select and menu are fine). It’s not a huge issue as I’m assuming this may be something that needs to be updated in Roomie to support the new Apple TV (v3 - 1080p version).

In my living room, I have a similar setup except I have the Apple TV (v2 - 2010 model). This does not do 1080p which is fine because I have an older Samsung DLP 60" TV; it can do 720p and 1080i, but not 1080p. That said, no matter which IR2IP port I use, even trying the IR blaster in port 3 (after changing the setting in the Web server page), the Apple TV will not accept commands issued by Roomie (on any iOS devices I’ve tried), even though the Roomie controls the newer Apple TV (v3) in the bedroom. I definitely have the IR controller over the Apple TV “eye” and I can even see the flickering when I send commands to it from Roomie. It’s clearly trying to control the Apple TV, but for some reason, Apple TV is ignoring it. I know the IR cables and ports are good because I’ve tried other devices and the power/input toggle for the TV is working fine when I choose Apple TV, just nothing else (menu, directional/select, play/pause).

In both the bedroom and living room, I have setup the iTunes pairing so that Roomie can control iTunes (and that works), but that has nothing to do with the physical control via IR2IP of the Apple TV. Why the Apple TV V3 works and not V2 has totally stumped me.

If anyone can help, it would be greatly appreciated!!!



For the first case, it sounds like you have selected one of the other Apple sets that isn’t the Apple TV set. Make sure to select Media Player->Apple->Apple TV.

For the second case, you just need to “unpair” that Apple TV from its remote so that it is not locked to a particular remote.

For the first case, I have selected Media Player -> Apple, then Apple TV automatically shows up. There are no other choices. This process worked perfectly in the bedroom (which has the Apple TV v3 - 1080p) but I still cannot get the Apple TV remote (virtual or not) to function at all in the living room (within Roomie).

I’ll hold off the trying the second case and will stick with the virtual remote for Apple TV in the bedroom).

Well, I went ahead and checked for the second case and found the problem that caused the first case: the fact that the living room Apple TV was paired with a remote prevented Roomie from Controllinit a whatsoever. Upon unpairing and rebooting Roomie, the living room Apple TV can now be controlled by Roomie as well!

The guest room was never paired to begin with and it worked fine with the physical Apple remote, the Apple remote App and Roomie with no issues (except the play/pause button only works in virtual remote mode, not Apple remote model).

I believe the issue with the Apple remote in Roomie (as opposed to virtual model) not being able to do play/pause is indeed a bug, let me know if there’s anything else for me to try (It happens on both Apple TVs).

Yes, the Original Remote button mismatch for that command is a bug. If you need it fixed, we can send you a command set for it from support. It will also be fixed shortly in the general library. For now the Virtual Remote works well.

Thanks, I’d appreciate the command set. When you say “fixed shortly in the general library”, does this mean it will come down with a new App update of Roomie or something else?

To clarify, we’re not support. That’s the link on the right side of this page.

The library is updated every week or two. You can watch the Devices and Codes forum here for updates.

Ok, I didn’t understand what you meant. If I understand correctly, the “library” will update upon a fresh launch of Roomie, correct? If I have iCloud sync on to use multiple devices, I assume the update will occur after launching the app fresh on each device. Thanks.