Apple TV3 and 4 Issues (Power On, Losing Control)

Hello fellow users,

First time long time, I began using Roomie in 2012, and haven’t used a physical remote since (except for Apple TV!). I have (3) Apple TV 3’s, and (1) Apple TV 4. All are updated to the newest software versions. Each of the Apple TV 3 have been restored from iTunes. None of them are subject to the recall. All of them are hardwired LAN (I prefer this).

My Apple TV3’s do not regularly wake on lan, and often drop control while in use (go back to “matching” or “verifying” phase in the edit device screen. This is after it having worked fine. The Wake on Lan also has issues, and works on occasion. I gave each of the Apple TVs static IPs, and they do stick. This increased reliability a little bit, but it is still a frustrating experience (especially for my wife, kids, and guests!). I began to assume that the Apple TVs, while not subject to the recall, have the same defects as the recalled units, so I bought an Apple TV 4, assuming it would solve my issues.

I love the Apple TV4 interface, what a massive improvement in UI/Os. However, the wake-on-lan NEVER works. I successfully linked the device in the App, but the same issues occur as in the 3, “verifying” or “matching” state in the device list. I have not given this a static IP yet, but that doesn’t seem to be the issue in the others, so I figured it’s not on this either. The unit is hard wired. I have excellent WiFi in my home, so I could try that again, but I prefer hardwire gigabit when I can.

Equipment in the chain:

  1. Fios Quantum Gateway (AC 1750) G1100 - Assigns IPs, wifi off

  2. Asus AC-88u - provides the wireless networks, and plugs in to the network switch

  3. NETGEAR JGS524NA 24-Port Gigabit Ethernet - Distributes hardwired connections throughout the house

  4. NETGEAR 8-Port Gigabit Ethernet Switch (GS608NA) - Takes the line from the 24 port and distributes it throughout the master bed room

  5. Apple TV4 and TV3, both hardwired.

  6. The other Apple TV3s are connected directly to the 24 port switch.

I’m at a loss, and have been at this for a while. Running out of energy, but paying a professional to do this is probably a 5 figure job in my area. Not interested in that, and don’t really want to go with a Roku or Fire TV. I do have two fire TV sticks, and they work perfectly over IP, as do all my other IP devices (iTachs, Insteon, etc). Thanks for your help.

Some Apple TV 3 units had wake issues as you note.

No Apple TV has ever supported Wake on LAN. They are either set to stay awake in which case they are easily (when working) awoken by any command, or they’re not in which case you need to IR wake them.

I’ve never heard of an Apple TV 4 with a wake issue to date. When configured properly in Settings, any command wakes them. If your ATV3 is configured properly and does not wake reliably, it probably has the hardware issue. I would recommend a Blaster in your equipment rack as a backup in that case. All it needs to do is turn it on.

But, these days, TBH, better to just replace with ATV4 that has no wake issues (when configured as such). It sounds like your confusion is mainly that Wake on LAN played some role with Apple TV which it does not. Wake on LAN works with very specific devices that have chosen to support it. Many devices simply turn on via normal commands at any time. Apple TV is one of those if you didn’t make the mistake of sleeping it.

Ok. So that all makes sense to me. So 1) what setting is messed up on the ATV3 ? 2). What about the ATV4? Something about auto sleep??

I think you can’t get it wrong on an ATV4. I just checked one I am certain wakes all the time and it is set to auto-sleep in 1 hour, so even a sleeping ATV4 works fine. I don’t have an ATV3 in front of me to check, but definitely you want to set anything that sounds like sleep/wake to wake.

Thanks for the responses.

Any idea about the drop in control, when state transitions to “matching”/“verifying “ and codes sent show up red?

That “matching” stuff is totally irrelevant. The UI in V5 has been improved to remove that. Too many users though it had something to do with control or connectivity. It does not.

Red commands mean the target device is not responding. So that would be presumably a misconfigured or problem ATV3.

My AppleTV (Gen 4) works fine with Simple Control (even if it’s fallen asleep). I just check this Activity startup-commands for you. Actually, it’s just list ones for the other devices (amp, etc.). I’m also using wired, but with a Fixed IP. If not using static IP, I suggest you at least Reserve it’s IP at Router.

I can’t really help with AppleTV-3 models. Just so you know, that is a completely different machine from AppleTV-Gen4 and recently released Apple-TV-4K (which instead run on the newer tvOS).

I also had an issue with my AT4 not waking up. I worked with apple support on the issue and suggested the issue was most likely caused by an ethernet switch. I moved to a wifi connection (luckily right next to an airport express) with a fixed IP and it seemed to have solved the issue.