AppleTV Wake on LAN

AppleTV IP control has been working like a charm, but I have one unresolved issue:

When the AppleTV goes into standby mode, it doesn’t seem to wake for IP commands (I’m connected over ethernet even, not wifi) so I need to use infrared to send any command to wake it up before it’ll respond.

Best ideas for how to handle this? Not super hopeful at this point because Apple’s own Remote app doesn’t show standby AppleTVs in my experience, so it may not be possible…

Typically that means your model is part of the massive 2013 Apple TV recall. Information on that is linked from the FAQ:

To clarify, a working Apple TV does not require anything special to wake up. Any simple IP command such as MENU TOP or CURSOR DOWN will work fine. We have a recall unit here that behaves as you describe that hasn’t been swapped out.

Sending an infrared command to a recalled unit does generally wake them and then they accept IP control, but obviously getting a repaired unit would be better. All the non-recalled units here and the great many we’ve now supported via support are able to wake with any old IP command.

Separately, there is some debate about whether Wake on LAN is useful with Apple TV. We’re not going to say there’s no use for that, but we have yet to see the case where it is.

Thank you.

Thanks for that info! Looks like my unit is indeed part of the recall, I’ll be heading to the store to get it replaced.

Thank you for the detailed information.

My Apple TV isn’t part of the 2013 recall and connects over Ethernet. It does exhibit problems waking up over IP.

I will try a restore like you suggested and keep you posted.

For your information, restoring my Apple TV as per your recommendations did fix the IP wake up issue.



Posting this FYI for Roomie and for anyone who is still having this problem with AppleTV 3s that are not part of the recall list and been restored in iTunes. During testing I got the exact same results using the Apple Remote app so it is definitely an Apple TV 7.0.2 bug.

I tested 3 new AppleTV 3s, with different source build locations (serials starting with C, D and F) all purchased this week and all on 7.0.2. Apparently there was a bug in 7.0.1 that did not allow AppleTV 3 to wake up. This was fixed in 7.0.2 but for wireless only. My ethernet connected AppleTVs would not wake, I ran many hours of tests and when I switched to wireless it worked fine every time! But that is not a solution.

I sent Apple feedback and would appreciate others do the same.

I spoke too soon, the issue cropped up again a couple of days after the the firmware restore.

Interesting find MarioG, I will send Apple some feedback regarding this issue as well. I prefer to use our AppleTV over Gigabit Ethernet as well.

I don’t know about you but Apple TV 7.0.x has been very unstable so far (unstable iTunes AirPlay audio stream, unstable Netflix and PlexConnect video streams). I have to reboot the device every other couple of days.

Update for interested parties: I sent Apple Wireshark traces, logs, etc. about 2 weeks ago. Yesterday they asked me to test 7.0.3 which just came out. No change so problem persists. There is also a bug that causes AppleTV 3 to issue endless DHCP requests every few seconds, but only on ethernet wire not wireless. If anyone has the time please open an incident with them (not feedback) about Apple Remote not waking AppleTV when connected ethernet.

MarioG by incident you mean calling up AppleCare ?

FYI to interested parties… Apple TV update 7.1 finally fixed this! It also fixed the DHCP problem but introduced another DHCP problem, it took 5 addresses! At least Roomie and Apple Remote wakes it up now. If you have the wake issue update to 7.1.

I have the same problem, ‘wake’ from sleep only works on a wireless connection. I have updated to firmware 7.1 and the problem persists.

My Apple TV is not identified as part of the recall.