Control of iTach Wi-Fi over internet

I have my WF2IR set up and working on the local net work.
I have set up a URL for the WF2IR.
When I go to the setup page for the WF2IR appears.
How do I get Roomie to send the commands to the URL?
If I add a device enter the url and port --> then Global Cache the WF2IR is not a choice, just Contact Closure and Gc-100 Contact Closure.
Same thing if I try to edit a device.

Well a lot of this depends on your network. If the router is set to forward port 80 to the gc-100 then it’ll do that. You cannot connect to everything through the same external port. What it sounds like you want is a VPN instead. Most mid to high end routers support this, as do all android/iOS devices

The WF2IR is the only thing on port 80. I don’t even have a GC-100 or Contact closure they just show up in the choices. I can login with a web browser but Roomie can’t find it.

Port 80 is just the user front end for the iTach. The iTach operates for infrared on port 4998. So basically you would need to edit Roomie.plist directly to enable this. Change or whatever the address is of your iTach to “” or whatever your DNS name is for your home address ( is typically used for this purpose to eliminate the issue of changing IP addresses). That would be the only edit you’d need to make. Then sync that change back from your Dropbox.

Now, the problem with that whole scheme is that there is no security. Even if you had a password, in the context of the whole Internet, that’s very weak. You really want to setup a VPN. If you do setup a proper VPN, you don’t need to make any changes to your Roomie.plist file. There are many VPN systems that work with the built-in VPN software in iOS either software that runs on a server or on a router. We don’t specifically suggest any, but given a properly setup VPN, it is both secure and requires no special Roomie configuration to control for instance an iTach or anything else from Roomie over the broader Internet. While the hack in our first paragraph will also work, we strongly recommend the VPN method.

I been tied up with work for quite some time, and haven’t had a chance to work on this. Yesterday a I got some time to see what’s involved. Setting up the VPN server is out of my tech skill set, so I downloaded VPN Server Configurator for Mac and VPN Client Configurator for Mac from and ran the software. On my Airport Utility under Network clicked network Options clicked Enable NAT Port Mapping Protocol and set Enable default host at the network IP of my new VPN server.

All seems to work fine