Debugging SmartHome Alexa Skill Issues

I have been using the SmartHome skill somewhat successfully but have a couple of issues I haven’t been able to resolve. I would appreciate any suggestions for debugging.

  • I have an activity named “Watch DirecTV” in the room “Living Room”. One of the commands is a “power on” command for the DirecTV receiver. The activity works fine from the phone app, but when run from an Alexa voice command the DirecTV receiver always fails to power on, while all the other commands work as expected. A “Power-Off” voice command for the Living Room does successfully power off the DirecTV receiver so it’s not a question of the Hub being unable to control the DirecTV receiver. Why would the Hub fail to successfully execute this command?

  • When I have Alexa discover devices, it fails to discover the “Watch DirecTV in the Living Room” command. I have to use “Tell Simple Control to Watch DirecTV in the Living Room”. A similar activity “Watch Amazon in the Living Room” does work for my FireTV. Why would the SmartHome skill ignore the DirecTV activity?

In general, I’m very happy with the SmartHome integration but can’t quite get everything to work.


As is the case with many thread-starting posts here, this is much better posed to actual support people than to a user forum. I’m not sure how anyone in the forum would know the answer to this because the answer would require looking at a diagnostic of what is actually going on and what you have actually configured. At best someone would make an educated guess without such information.

One of the things that does seem likely from your post is that you’re having decode issues with the word “DirecTV” and Alexa. It’s a confusing word for Alexa that must be perfectly enunciated for it to be understood. I suggest thinking of saying “Direct Tee Vee” instead of “directv” as that seems pretty reliable.

Thanks for the response Will. The DirecTV word does work for other rooms and I have tried other words in the Living Room without success. I have opened a support ticket for the hub issue.

With a suggestion from SC Support I was able to resolve my issue of the Hub being unable to power on my DirecTV box. There is a setting in the DirecTV box under Whole House settings where it’s necessary to open up permissions for External Devices. There were several categories and it wasn’t very intuitive, but the hub worked after I opened them all up. It’s not clear to me why the hub commands are treated differently from phone app commands bu that seems to be the case.

I found the best way to sort naming problems is to use the Alexa app and create groups, even if the group has only 1 member.

I create a group called “TV” and I put the “Watch DirecTV” activity into it. Now the alexa commands can be “TV on” and “TV off”

This is the best way I’ve found of keeping names short and clear for Alexa without having to change them in Simple Control and then they are not what you want when you use the app on a phone or iPad.