DirecTV No repeats

device is HR24. using roomie virtual up and down navigation buttons. One touch often causes the unit to go up more than one item, sometimes as many as five (as if i touched the button 5 times). Sometimes it does work one = one. but not always. This is annoying when scrolling my list of recorded programs. How to I calibrate so one touch always equals one movement?


If you using IR, what are your repeat settings set to?

i’m using ip

You can force one touch to always be one touch on that device. There is a second set of commands on the Virtual Remote that begin with “NOREPEAT”. Swapping the command in the Remote Design assigned to the directional pad buttons with the same command from the NOREPEAT commands will eliminate any possibility of skipping.

So THAT"S what that was for. I just deleted that last night. OK, i’ll try my best to find it and reassign. Is there a manual somewhere that can help? There are so many features on Roomie, I would love to know what they are to not only solve problems but customize things for the way I use them.

Just delete the Remote Design you have and it will re-create automatically with all the default commands in it.

I’m glad I found this! My scrolling commands through IP to DirecTV DVR were looping anywhere from a few times to almost infinite looping where the guide would just sit on the screen and continually scroll for over 30 seconds after a single command was issued. So far so good with the NOREPEAT commands, its been working fine all morning now. What I noticed that seemed to be related to the problem was that sometimes the network traffic progress circle on the status bar at the top of the iPod screen would be spinning almost non-stop like I was having connectivity issues, and during those times the looping command problem would happen. If the network traffic spinner was “quiet” then the commands would work correctly. I have Roomie installed on iPod, iPad and iPhone and it was doing the same thing on all 3 devices.

Pardon my confusion, but how do I reprogram the cursor functions on the directv virtual remote to use the norepeat option. From the post above, I see when using the remote I can select the “no repeat” button and then from the pop-up menu the desired cursor command, but how do I change the built-in Roomie cursor pad action? Do I need to delve into plist editing or is there a simpler way?

Just edit the Activity in question, and on the Edit Activity panel tap ‘Remote Design’. You’ll then see how you can easily edit each button and which command it sends.

Thank you.

Thank you!

Is there a full Roomie user guide/reference doc, e.g. a pdf or equivalent that completely documents all the capabilities and functions?

I’ve only been using Roomie for a few weeks and I am continuing to be pleasantly surprised at the depth of capability that is available as one delves deeper into the app, but a full-blown manual would be great.

I know most people don’t “RTFM”, but at some point some of us interested in going deeper would appreciate a full reference instead of learning by discovery/experimentation.

P.S. Thank you for the excellent online support. It really makes a difference!

A few months ago, I was happy to find this thread, because the no-repeat commands solved my problem.

They worked well for some time. But recently, for some strange reason, the no-repeat commands weren’t “registering” on my DirecTV receiver at all. So, that night, I replaced them with normal commands, and all worked well — until a few nights ago. Now, one tap is moving the cursor by 2 or 3 steps again.

So, I want to switch back to the no-repeat commands — except now, the no-repeat commands are missing from the list of available commands.

I’m quite puzzled, as this was very simple, both of the previous times. What would cause the no-repeat commands to disappear? (And yes, I’m selecting the correct component — the DirecTV receiver.)

Please see the last post in this thread for the resolution to that:


Thank you.

Thanks for the reply. The referenced thread states, “when adding the device, select “Older Models.””

But what if we’re talking about somewhat complex, existing setups that have highly customized remote designs? The referenced instruction seems to require “starting over” and building everything again from scratch. After the many hours I’ve spent customizing, I sincerely hope that’s not what’s now required, just to get those commands back. Please advise.


Remote Designs are based in general on a default device unless you created it entirely from scratch. A very cool part of Remote Designs is that they allow swapping out the default device to a different similar device without harming the integrity of the commands in the Remote Design. So it is likely to just swap out trivially for you in the general case when you add the new device, delete the old device, and then set the new device to be the ‘Opens Remote’ device for that Activity with the same Remote Design.

Thank you.