Epson TW9400 Projector

I recently updated my home theatre with a new Epson TW9400 projector, but I’m having difficulty with controlling it.
I have gone through the sequence of “adding the device manually”, inputting its IP address, tried the recommended port 4352 number, tried both the “all models” and “PJLink” types, but no luck.
I also did a scan of my network to confirm it’s IP, plus a scan of the open ports that it is using (80 & 5357) and tried both of these, with both model types. Again no luck.

Anyone had experience with the same projector model / if they overcame the problem?

I don’t believe that model can actually be controlled via the Network. The LAN port is only used as an alternative to transmitting images to the projector. I have an Epson 4k projector that has similar functionality.

You’ll need to use an IR Global Cache’ iTach IR transmitter (supported by Roomie Remote) to be able to control the projector. You can find the instructions on how to use the iTach transmitter on this site. You can also link from this site the Ethernet or Wifi version.

It’s not terribly hard to set up, but the Epson IP address won’t help you. From Roomie Remote, you’ll scan for the Global Cache’ iTach device, then “learn” the control codes.

Good luck.

Thanks for the response and information. I was starting to conclude that IP control was not possible.

Luckily I DO have an Ethernet version of the IR controller, this was used for my old projector, plus control of my Clipsal C-BUS lights.

I have “learnt” the codes and now have control, not preferred but it works. TBH, I only really need to turn the projector ON and OFF as part of the activity.

Maybe at some point IP control will become available.


Glad you got it worked out!

They have an app which can be controlled by IP which I use. It’s called iprojection.

Thanks for the comment Frank. I had noted that Epson have their own app, for various functions, although not sure if any of them are of much use in my home theatre set-up. As I mentioned in an earlier comment I only want to turn the projector on/off with roomie, so IR it had to be :confused:.

You can turn it on and off with Roomie using IP… I do. You have to select PJ Link. Type your ip address and use port 4352.

I’ve been doing that for quite awhile. It’s the other functions that’s don’t work which you will need to use the Epson App.

Hi Frank, Yes I’ve tried that but still can’t get it to work?? Not sure what you are doing differently?

I’ve added the “device” (projector) manually with its IP address, selected Epson projector, entered port 4352, and used the PJ Link category. Then when selecting the “test” button to test, it gives me the Epson control bar, which drops down to three more buttons, “Input”, “AV” and “Power”, the latter giving me “Power Off” and “Power On”, but pressing these nothing happens??

I’ve noted, scrutinising on my network, that the projector “disconnects” itself from a local Ethernet switch when turned off, so I thought that might be the problem, but turning on the projector via its own remote (so it reappears on the network), then trying the “Roomie” remote control to turn it off, it still doesn’t turn off, so that theory sort of rules that one out.

Don’t know what to try from here :thinking:.
Will probably resort to the IR control which IS currently working :smirk:

I’ll have to check.on my end on the projector menu.