Flex is sending multiple commands for both TV and cable box

I have an Element TV with an Xfinity X1 cable box controlled via wi-fi and a Flex (with latest firmware). It worked fine for a few months.

I haven’t used Roomie in this room for a while. Just today I switched the TV on with my iPad and found something very weird. Every time I selected a digit on the remote in Roomie, I got the digit repeated 6 or 7 times. I also couldn’t change channels using the guide. With all the multiple digits, I can’t change channels at all. I tested the TV and determined those iR commands are duplicated too multiple times. Something is very screwy.

I rebooted the Flex, TV and cable box (power cycled). No change. I tried both my iPad 4 and iPhone 5 with the same results. I tried my other three rooms with iTachs (Ethernet) and experienced no problems.

I did upgrade to iOS 7 on both devices yesterday, but unless there is something Flex specific, I doubt it is iOS 7. All other rooms and functions work just fine.

Any idea what is going on with this room and/or Flex??



Fellow Roomites … I/we can stand down!

I discussed the problem with Global Cache support. It turns out the 08 firmware had a bug that sent multiple commands. They were unclear if all 08 downloads had the bug, or just some of the 08 downloads.

Anyway, 09 is out and that cured my problem and eliminated the duplication duplication duplication bug.

I can also say with certainty, Roomie is working well on both my iPad 4 and iPhone 5 running iOS 7.