Flex - Too many transmits

I recently setup two TVs with Roomie and iTach Flexes. Almost everything is great, but I am having one issue. I have the retransmit count set to 1 for both my TVs (Vizio) and my AppleTVs, but every time I tap an onscreen volume or arrow button for one of them I they get ~6 presses. That makes navigating on the AppleTV very difficult, and causes the volume on my TV to jump around a lot more than I want.

I am relatively certain this is an issue in Roomie and not the Flex, since when I use the hardware volume buttons on my iPhone or iPod I am able to increase and decrease the volume of the TV by single increments. Is there something different in that code path?

For the moment my solution is to use hardware volume buttons in Roomie and switch to the Apple Remote app, but ultimately neither of those will work if I want to lock my iPod touch into Guided Access mode so it instantly brings up Roomie when I wake it up. Any ideas would be greatly appreciated.

You can also force single transmits by editing the Remote Design and setting the command itself for the cursor buttons to Repeat -> None instead of Repeat -> While Touched. Basically the hardware just isn’t stopping its transmissions quickly enough. But setting the button itself in the Remote Design not to repeat will make sure that only one transmit occurs.

We have only seen this with the Flex and we believe it may be fixed in the firmware update they are due to release imminently.

We would suggest also expressing your interest in this via support@globalcache.com.

Thank you.

The firmware did not fix it, so I altered the remote. That is less than optimal as I have to explicitly tap multiple times, but it is workable. I will contact globalcache.

Hi Lgerbarg


I have the flex wifi since the firmware update the tri port lead has not been working it now only works on ir3 do you have the lead and if so is it working on yours looking on the itach forums seems one or two have this problem

I too have this issue with a flex and blaster+2 on updated firmware, AppleTV is on IR2. Today, I ran a Wireshark trace that showed Roomie sending only 1 command. I will send the trace to Roomie and GC in case they don’t already have one. For now, setting repeats while pressed to none is ok.

Bad news for us with AppleTVs, GC checked the Roomie commands in ther trace and seems to think it’s the AppleTVs fault. Does anyone have AppleTV wirking fine with the older iTach? Also, if you have this problem with the Flex and AppleTV (or any other device) please contact GC as they said no one else is reporting this. Thanks.

It’s not Apple TV’s fault. It’s just a timing issue. Apple TV is extremely sensitive about the duration commands are sent. So when Roomie tells the iTach Flex to stop sending, it needs to stop right away. This process takes milliseconds longer on the Flex than the original iTach. Too many milliseconds means an extra transmission. Definitely something that should be correctable in firmware. We will follow up to see if they need any further details, but note that the number of users reporting this to them is likely to correlate directly with the speed of resolution.

Thank you.

We’ve confirmed with Global Caché this is due for a fix in the next firmware update.

Thank you.

I’m also experiencing this problem with my Apple TV, Topfield TF5000PVRt channel controls, and Yamaha RX-661 AV Receiver volume.

I’ve emailed Global Cache as requested but am wondering if they have given you any indication of a release date?


Global Cache Supported responded to my email and said:

The updated firmware will be released this week, and it will be fixing the repeat issue that you are seeing.

Firmware 06 for the Flex was released lastnight. We are working to verify fixes. At this time there are reports of some issues. That may be premature as other reports indicate some serial issues were verified as fixed. We would advise holding off on updating for the moment until we report back.

Thank you.

I upgraded my to 06 before the above warning and now IR codes are not sent reliably at all. I’ve logged a support request with Global.

GC backed out the firmware on their web site. If you have a Windows machine run ihelp from the web site and it will put -04 back on your flex and IR will work again. I don’t use Windoze but had it as a VM under Linux and OSX so was lucky.

The mac version of iHelp has been updated and now upgrades the Flex to version 04.

We have tested Firmware 7 and we believe all of the infrared issues with prior firmware releases have been resolved in that. We recommend upgrading to this release. Firmware upgrades for iTach units are performed via Global Caché’s iHelp utility:


Thank you.