Getting Roomie MUTE Control to Work on Oppo BDP-105D

I’m using Roomie to control my Oppo BDP-105D via IP. I cannot get the MUTE command to work.


When I push the Mute button in “Edit Device > Test Remote” mode, nothing happens. Evidently, no command is sent, because the command name does not appear at the top, either in blue or in red.


I tried to fix this by creating a RoomieCodes.plist file, per the DDK. My file looks like this:


<?xml version="1.0" encoding="UTF-8"?>




All Models IP









(I found a list of IP commands here: … authuser=0)


The file loads without incident via Dropbox. Once loaded it appears to override the entire default Oppo remote, and replace it with a minimal remote containing only the simplest 4-icon control (mute, vol up, vol dn, gesture button), along with a single text button, “Mute”.


The text button seems to send the MUTE command (it appears in blue at the top), but it has no effect on the Oppo. The 4-icon controller generates no blue commands and appears to send nothing.


Any ideas how to get the Roomie MUTE control to work on the Oppo? Or more generally, how to insert functioning IP commands into an existing command set to fix/add commands (without overriding the existing set).




Just sending “MUT” to the Oppo would be their serial format, not IP, so that will not work. What you would want to do this on your own would be to rename your custom set to “Supplemental Commands” instead of the internal name “All Models IP” and then fix the format of your command to the format shown in their document which is like this below, you would want to paste this into Xcode to make sure the formatting was preserved and make sure the keywords are exactly as shown for Roomie substitution of the MAC Address and request ID (TAG):

<?xml version="1.0" encoding="utf-8"?>


However, also note that this is probably better handled by contacting support. We’re happy to add missing codes and deploy them to production all the time.

Thank you.


  1. I contacted support as you suggested.
  2. I tried your IP code and it worked! Xcode properly serialized your XML snippet above as a string, under a I called "MUTE". Then in Roomie, when adding a device, I was presented with a new list of Supplemental Commands (containing one text-button command: MUTE). I tried the resulting (minimal) remote, and it correctly toggled MUTE on the Oppo. Success!
Questions (in order of importance):
  1. How to merge the new mute command with the other "All Models IP" command set, so that the new mute command is on the same screen as all the other Oppo commands?
  2. How to associate the new mute command with the mute icon (little speaker with a line through it), rather than a "MUTE" text button?
  3. How to get rid of all the repetitive "Supplemental Commands" sets that accumulated in Roomie while I was testing?


If you add a supplemental code, you want it to remain a supplemental code. You would then add it to your Remote Design as a button for instance. A Remote Design can target any number of devices.

Any button can use an image or text by editing the Remote Design. The image you’re referring to is built in and available for your use.

The “Custom Code Sets” section of the Settings panel shows you which custom code sets you have installed.

Thank you.