Global cache 100-12 questions


i recently obtained a secondhand global cache 100-12 which I intended to use with roomie. Unfortunately i cannot get the device working. I am assuming that the issue is to do with the firmware which is version 2 not above 3.0 as recommended.

I was wondering if someone could answer the following questions:


  1. should the gc100 be automatically detected? (From its UDP announcements) , I cannot get roomie to detect the device. But it works fine for the manually configured relay switch.

  2. what is the difference between the version 3 and 2 firmware and what causes the incompatibility with roomie?





  1. No, because the firmware is not 3.0.
  2. There are many differences and fixes there.

We recommend the iTach series (even if you have a GC-100). Upgrading the GC-100 is a lengthy operation involving sending it back to the factory. Getting an iTach would be much better than that.

Thanks for the reply. I could see that the version 2 device does not perform the multicast announcements.

I have some good news in that I managed to get the version 2 device working with roomie. I took a look at the gc100 API and knocked up a node.js app that performed the multicast that seemed to be missing.

Once I did this roomie picked up the GC-100 and now works perfectly :slight_smile:.

If anybody needs any further details on my solution please let me know.



We would just note that discovery was only one of the issues there. It may appear to work because the basic interface is similar, but we would not be surprised if you find other issues down the road. Meanwhile though, if it works it works and that’s great.

Hi Thanks for the reply. I’ll keep an eye out for any instabilities.

I am very impresssed with roomie now I have full IR control in place. well done on a great app.


@trickydee: I just ordered a “cheap” used GC100… before looking at this stream. Might you pls tell me if you are having any problem with Roomie + GC100 (serial and IR) and how you did manage the node.js app?

Unfortunately I cannot say, yet, if I’ve a version 2 or 3… (but Murphy suggests it will sure be a version 2;)

Many thanks!

Hi there. I’m in exactly the same boat. Bought a used gc-100 with 2.0 firmware. I’m in South Africa and I doubt upgrading the firmware will be easy. Getting access to your node.js solution will be highly appreciated.



Hi Jim / Acambitsis,

Sorry for the late reply. I actually stop using the gc-100 with roomie as I ran into some other issues. Just like the roomie guys said, every so often the GC-100 would stop working. It became quite annoying, such a shame.

I spoke to the guys at global cache and they advised that the unit could be updated to the latest firmware for $30, but it would need to be shipped to the US as there are no other resellers that can update the firmware. I don’t mind the $30 but the shipping made that quite expensive for me.

Personally I would probably look at picking up one of the newer itach flex units, unless you need the relay functions that you get in the GC.

Btw I can dig out the node.js code if you really want it. But I think the other limitations of the firmware will surface and make the device unusable until rebooted.





Thanks, trickydee!

Obviously when I received my unit, it was a 2.0 firmware. I had to hardware reset it to make it visible. Then it seemed to work… but as soon as I tried to change a serial port configuration from 19200 to 9600 baud it freezed completely.

I tried with another reset (connecting the two rs232 pins with a flat screwdriver) but… boom… now it doesn’t anymore start and present all the IR leds flashing (ie. It doesn’t pass anymore the initial self test). Probably something has one wrong with the reset… Deceased unit… :confused:

I bought the GC100 for the serials (to connect a Rotel Rsp1066 and a Pioneer Kuro TV and have some feedbacks), to improve my current wifi iTach setup.

Now… back to origin: have to spend other money and understand if to buy a new Flex unit to drive only one serial unit (the Rotel). But I saw across these forums that Roomie does not manage - at now - the feedback from Rotel pre-processor units. So I’m not so convinced about this new expense…