Insteon 2412n Central Controller

I added a 2412N and a few scenes for basic lighting control. The Roomie autodiscovers the device and I can add that. However, it does not appear to scan the 2412 for scenes and/or device codes. Do all the codes and Activities have to be added manually?

The Device IDs need to be entered. The ISY99 lists out scenes and device (among many improvements in that unit). The 2412 does not.

I had a terrible time programming the 2412N, partly because some of my switches are in J boxes that are hard to get to. Then I discovered that the IR linc works perfectly. Back to the 2413U and indigo with great success.

I’m also having difficulty with my Insteon 2412n. It sees the controller but no go when I enter the device code. Is there a step I’m missing? I’ve also tried to reset my router as that helped with my Grafik Eye IRI

With the 2412n controller the test remote and device ID will not work. You have to add the device ID info in the “add an activity” setup section of Roomie.

Yes, DenverMDM, I had to do the same. I am thinking about getting ISY99 not only for roomie integration but also for a more robust system that I hope is more reliable than the 2412n. I am still having trouble with devices not turning on and off consistently. Since there is two-way communication with insteon you would think the controller would fire another command if the status doesn’t match.

The 2412n supports controlling X10 devices. Is there a way I can program X10 device ids into Roomie?

The .X10 COMMAND command in the SmartLinc command set in Roomie allows sending X10 commands as documented in the 2412N manual on page 12:

So as per the example on that page, what you enter into Roomie for the .X10 COMMAND parameter is whatever is between the 0263 and 80.

Got it, thanks!

I am having a problem with my 2412n - specifically the 1st command I send to it never works but the subsequent ones do. I’ve tried resetting it, tried both without and with authentication, etc but if I quit fully out of roomie, the 1st command does nothing (even though roomie reports it in green) and then the second does work. It is very repeatable and does not matter which command I use (tried several scenes and both on and off)

A friend of mine who also uses the 2412n and Roomie with a very similar config does NOT have this issue…

Anybody ever seen this? Any suggestions what I might try?

My next thought is to stand up a proxy so I can watch the HTTP traffic and see what is happening…

Well for reference, I deleted and re-added the unit manually (not using the auto-detect) and now it works fine.

Not sure if the delete/re-add fix it or not using auto-detect fixed it…but if somebody else has this issue, something they can try