LG WebOS OLED C2 not controllable


I have a new LG OLED C2 (2022 model). It was working just fine with the Roomie remote until recently. I have tried everything I can think of to make it work, but no luck.

Starting from scratch, I deleted the existing device.
Roomie discovers it with the correct IP address, sees that it is an LG TV. None of the test functions work.
It is picking a MAC address that is not the TV’s, I have set that to the correct MAC address (which took several tries for it to stick), but still no luck.
I have gone into the service menus and made sure IP control is on.
It is picking port 3001, before it was 3000, and the IP control docs for the TV state 9761 is the correct port, none of them work.
I have the TV wired, I can ping it. I can telnet to it.

I seem to remember maybe having to put in a code or something, but I cannot get it to do anything.

Any thoughts on how to get this to work?

Roomie 8.3 fixes the LG C2 issue they broke in a firmware update last week.

After updating to 8.3, first “Force Code Set Update” in Settings. Wait until it finishes. Then open the LG device you have and change the port from 3000 to 3001 or just add it as a fresh device. Make sure your Primary Controller gets these changes (do them from that device) as all commands to LG TVs are sent from your Primary. For hygiene purposes, force restart everything after all of the above.

The MAC address is taken from what LG gives us, but can be wrong because they only give us one, and depending on whether you’re using Ethernet or Wi-Fi, it might not be the right one for you which is why we would always advise verifying the MAC address manually.

Thank you! I already had 8.3 but forcing the code update did the trick.


I am running RR 8.3 on all devices and always do a Force Code update after a Roomie update. I have 3 LG TVs in my system. A 2021 65"’ G1, 2017 65" G7, and a 2022 55" NANO. All are on Port 3000 and mostly work correctly with RR. Is there any advantage to changing to Port 3001? Looking these devices as a Discover on Local Network defaults to Port 3001. The network identifier does not match the MAC addresses for either Wifi or Ethernet. Should I enter the correct MAC address or leave the default as is? Proper Network Identifiers have often been confusing to me.

This has nothing to do with other LG models at present. You can apply the same change to your devices without issue, but there is no actual need at this time. If you use Wake on LAN, you must make sure the MAC address is correct.

@Will_Price I have tried above method.

  1. force code set update
  2. add new device through local network discovery
  3. when I click test
  4. TV shows pair code, I enter the code in Roomie, click done.
  5. I can now control the TV
  6. click Done, it brings me back to add device screen, and ready to add device.
  7. After I completed the add device steps, and click newly added TV again, I no longer able to control it.
    It appears it only work in the first time adding and test mode.

Is there something i am missing?

Step 7 means your primary controller is not in sync or not updated. Step 5 happens locally, step 7 happens on your primary.

Ahhh, I am using Apple TV as primary control, and step 5 is done on my iPad.

Do I need to close Roomie on Apple TV and restart to sync?