Mi Casa Verde Vera Lite Integration

Can you provide a bit more detail on how to setup Roomie with the Mi Casa Verde Vera Lite? I noticed that the Roomie Remote 1.7 release notes indicated that Roomie now has auto-detection support for the Vera. Unfortunately, my Vera Lite did not show up automatically so I tried adding it manually using the static IP address and the port indicated on the IP Compatibility list of 3480.

When I press one of the buttons on the ‘Test Remote’ function, I see a ‘.LIGHT DIM’ command in the top left corner.

From what I can tell, it seems like things aren’t working as expected or I am completely missing a configuration option. Any thoughts on what I should try?

When entering commands in for instance a Start Activities command list, you would add a command to your Vera where Parameter 1 is your Device Number from the Vera and Parameter 2 is the desired brightness level (some commands such as LIGHT ON or LIGHT OFF don’t take a second parameter as the brightness is implicit.

Thanks for the feedback. I had looked around in the Macro settings, but I may have just completely missed the option. I will take a look and report back.

Thanks for the feedback. I realize now that I just skipped past the “Integration ID” field as I didn’t know what it meant. After reading your message and then poking around the Vera’s web page, I was able to find the appropriate settings.

For anyone else who finds this message, you must first setup the Vera as a device in the room, then setup an activity. When setting up the activity, you will choose to manually add a command, select the MiCasaVerde Lighting, then choose a command category (eg: .LIGHT DIM, .LIGHT ON).

This is where I got confused as I expected the list of commands to specifically show all of my devices… I realize now that this list of commands is just the generic command and the next step is where you identify the device. After selecting the .LIGHT DIM command, you will be presented with a screen which has fields open for the ‘Integration ID’ and the ‘Brightness’. The ‘Integration ID’ is the ID listed under the ‘Advanced’ tab of the devices settings from within the Vera UI – I was initially confused by this as well because I was using the ID shown under the ‘Settings’ tab which is actually the ‘altid’ in the ‘Advanced’ tab. With a dimmable command (.LIGHT DIM) you will have the option to enter a brightness level between 0-100.

Note that the lighting commands can also be included in existing activities by entering into edit mode and editing the activity you want. This way you can have your home theater lighting automatically dim when you choose you ‘Watch Movie’ activity.

running a vera 3 here, Roomie 1.7 also did not auto-discover it. When i entered the IP manually it was able to connect and control it. Please let me know if there is any info i can provide to help debug the auto-discovery, happy to help. Thanks.

Roomie 1.7.1 released a few minutes ago might help with Vera 3 auto-discovery.

1.7.1 also did not auto-discover my Vera 3. Please let me know if I can provide any useful info. Fwiw, ivera and Automator apps both auto discovered the Vera 3 without any trouble (I just tested on the same iPad as roomie).

Okay. We have a capture of the Vera 3 so we’ll fix it in the next release. App Store submissions are basically shut down now until after the holidays so we’re just glad we were able to get 1.7.1 out beforehand and only had a moment to tweak this as a first try. For now Vera 3 should be added via Manual IP.

Also did not Auto-Discover for a Veralite

Thanks for all the great info… It didn’t auto discover on Veralite for me either, but got it to work by combing through both forums. There is information on the Roomie forum @ forum.micasaverde.com/index.php? … _msg=92968, but here is a quick summary that worked with Roomie Remote 1.7 and Vera firmware 1.5.

Vera Steps:

  1. Set up Vera with a static IP address (or have your router always assign the same one through DHCP) - For example: 10.0.1.68

Roomie Steps:

  1. Setup the Vera as a device in the room

Select/Create a room
"Add Device…"
Manual IP
IP Address you assigned above
Port 3480

  1. Create/Edit an activity

Select “Remote Design”

  1. Add/Edit a command button

Name the botton or select an image
"Add Command…", choose device "MiCasaVerde Lighting"
Choose a command category (eg: .LIGHT DIM, .LIGHT ON, .LIGHT OFF, .SCENE RUN, etc.).
Enter the Integration ID
For .LIGHT ON/OFF this is the ID number on the Advanced Tab for the device in Vera UI5 (you have to scroll down to find it and don’t use the altid)
For .SCENE RUN, you can find the Scene ID at the top of the Vera UI5 when you edit a scene
For .LIGHT DIM you also need to enter the Brightness (0-100)

That’s all there is to it… I’ve had fun adding lighting, screen control and other environment effects to each room and activity. Some as separate “Activities” such as “Ready Room” or “Read” that only control Vera. Others as commands within an existing activity such as “Watch DirecTV” where it will automatically make sure the screen is lowered, turn the lights to 50% when I pause the movie, etc…

I am impressed with the room/activity based user experience and it has a high WAF (Wife Acceptance Factor). Unfortunately, the Roomie Remote app does not let you get feedback yet (i.e., you can’t see if the light is on/off or what temperature it is).

Best of luck!

I can’t location the Integration ID. I tried the ID # that was two digits long. Which I tried but was unsuccessful. Was that the correct number or am I missing something?

I dont understand how do set up the Vera step. Could you be more specific ?

Thanks