Oppo 103 IP Control

I just updated to v1.7 & have quick start enabled on my Oppo. I can get the Oppo ios app to discover it & control it but Roomie will not discover it after several attempts. All of my other devices are discovered such as my AVR, Tivo & iTach. I was going to manually add it but don’t know what port to use? Any help would be appreciated.

Thank you

We’ve just seconds ago updated the compatibility list for today’s release. The port for Oppo is 19999 if auto-discovery doesn’t seem to work with your router. We’ve never had a real 103 in house for testing, so if you encounter any issues please let us know as this support is clearly hot off the presses. Thanks.

For some reason Roomie would not auto discover my Oppo BDP-103, but I was able to successfully add it to Roomie manually. I entered the IP address, used port 19999 & selected Oppo IP series. One thing I did have to figure out was the power commands. With quick start enabled it would not recognize discrete power on & off. It will not recognize power on at all & it treats power off & power toggle as a toggle only. This is possibly a limitation of the player or current protocols. Everything else seems to work as it should. I would request that the button options available to the non IP virtual remote & on the Oppo iOS app be added to the new IP remote such as Netflix & Vudu, etc. Also is there any word on if or when live feedback will be enabled?

Thank you,


We have been told live feedback is going to be added to the IP interface but no sign of it yet. We’ll certainly add support for it on our side when they do.

Yes, adding those buttons is something that can be done easily in a simple library update.

We’ve also been told the 103/105 should be able to power on via IP, but we note that Oppo’s app does not do that. So we theorize that using +WAKE ON LAN from Roomie and manually entering the real MAC address of the box might power on the 103/105 models.

(Meanwhile, we’re getting a 103 for ‘testing’ to confirm all that as well.)

Good to hear about the live feedback, I figured that would be the case. I am able to power on & off the player from Roomie & the OPPO iOS app with the power toggle (power off works as a toggle in Roomie). Power on is only capable with the 103/105 & only when quick start is enabled in the menu settings. So I had to play around with it a bit to create an activity, with the only negative part is not being able to use discrete power on/off (not a big deal). Hopefully I have been a help & thanks for yours!


I am also having no luck with Roomie discovery of OPPO 103. Is this something I should wait for…(on the horizon soon) or should I manually add it as per above? What limitations will adding it manually impose?

The 103 works fine modulo the auto-discovery. Just add it via Manual IP on port 19999 per the compatibility list.

The following steps will help us fix the 103 auto-discovery:

  1. Turn on ‘Collect Diagnostics’ in Roomie’s Settings.
  2. Open ‘Add Device’ in Roomie and leave it open for about 30 seconds.
  3. Tap Send Diagnostics and then turn off Collect Diagnostics and email us to let us know.

I have sent diagnostic report as requested. Let me know if there is anything else I can do.

I have the oppo 103 but it won’t auto-discover. i added manually using port 19999 but it still doesn’t work. I put remote in manual mode to test but it simply doesn’t work. Downloaded the oppo remote (thru oppo app) and that works fine. What am I doing wrong?


Figured it out. Restarted everything.

Funny, I was going to post exactly what cfrance asked.

Installed Roomie last night on iPad Mini, it found my Yamaha receiver immediately, but not the Oppo 103. Manually entering IP and port for the Oppo didn’t help, even after cycling power on everything. All devices are hardwired to a hub connected to my main router.

This morning I was going to try assigning a static IP to the Oppo to see if that helped, but after a long delay on the first button press, Roomie started to control the Oppo.

One question: do I need to assign a static IP to the Oppo anyway, so Roomie can find it after DHCP assigns a different address?

Very nice app, by the way. I’ve used four different Harmony remotes since the very first EasyZapper, Roomie is so much simpler.

Any device entered via Manual IP (and a few that aren’t) are always good to use a static IP. More recently in the past few years, the preferred term is to use a “DHCP Reservation”. So you would ideally never use a real static IP, but rather set a DHCP Reservation on your router so that your router knows to hand out the same IP to the same box every time and never give it to anything else. More discussion of this is in the DHCP FAQ:


Just got an Oppo 103 for Christmas and trying to get it to work with Roomie. When it is powered on, the Oppo IOS app can autodetect and also control it. However, Roomie is unable to find it. I tried to manually add it using port 19,999. Any ideas?

If you haven’t done so, In Oppo Network setup, find the IP address your router has assigned and enter that into Roomie along with the port.

You may also need to cycle power on the Oppo and restart Roomie. I wasn’t sure exactly what did it for me, but eventually Roomie discovered the Oppo.

You will also want to configure your router to reserve that address for the Oppo so it doesn’t change, or Roomie won’t be able to find it again.

One important tip for anyone adding the 103 manually: make sure to select “All Models IP” as the command set. The other command set labelled “BDP Series” is for Oppo serial only.

I think there might also be conflict between the Oppo app running and Roomie Remote. I suspect that there is some kind of binding that takes place. I was able to get it to finally work by powering off and on my iPad, and the Oppo as well. Hopefully this will help someone, and in the future Roomie can auto-discover the Oppo.

It worked!!! You’re great!!! Will highly recommend roomie to all my peeps.great customer support!!! You rock!!!

> I think there might also be conflict between the Oppo app running and Roomie Remote.
I never installed the Oppo app, and still had problems. As I said earlier, I'm not sure what fixed it, it just worked when I tried it again in the morning.