Oppo 203 UHD Player Power ON issue in Simple Control

I just got my Oppo 203. Everything seems to work in terms of the Simple Remote with the exception of power ON. I tried both Power ON and Power Toggle and even tried Wake On Lan commands in the activity and nothing seems to work. I have tried testing the virtual remotes power on function as well and it doesn’t work. If the Oppo 203 is powered on, all remote functions seem to work including being able to power it off. I have network standby enabled in the Oppo.

I am thinking it could be the result of the code set that Simple Control is using for the Oppo. I noticed under the settings for this device in Simple Control, it shows Oppo BDP 93/95 as the
Remote “Type”. It could be that the power on LAN function is different for the Oppo 93/95. Oppo suggested using BDP 105 as the type but I see no way to change the remote “Type” setting in Simple Control.

Any suggestions on making this work or any idea when you will have an updated code set for the Oppo BDP 203?

Remember to check our Twitter feed for 0 day things like this. The advice is to be found there. Just add it via Manual IP on port 436 as brand Oppo type Blu-ray Player with category Media Control.

Thankfully, we’re experts at reverse engineering as that is the one protocol that works right now and that is the one that Oppo never published. Apparently there is another port 23 protocol that we’ll likely switch to for discover in the next release, but for now 436 seems to work great including network standby in our tests.

I have a flood of device compatibility list updates to make like this one.

Thank you.

That worked! Thank you VERY much! Unfortunately I don’t really follow twitter but I will have to check that in the future!


I’m afraid that didn’t work for me. The normal discovery works fine.
I tried adding it in manually with the port you suggested and Media Control etc. but when I click on Test Remote - none of the functions worked.
So I added it back in again manually and this time instead of picking Media Control I picked one of the other options, test remote then works perfectly with everything.

However, I still have the issue that I can’t power on the 203 UHD if it’s already off??

Any other advice for this please?


This thread is very old. We long ago released software updates to fix auto-discovery to do the right thing here automatically.

Power On requires setting the options in the Oppo menu for Quick Start (or something like that, don’t have it in front of me).

Thank you.

Thanks Will,

I will take a look at that tomorrow and update with the exact parameter if all works well…


The current fix is to go into the Oppo settings menu

Go to Device Setup -> Standby Mode

From here select Network Standby.

Once this is selected the Oppo will now power on under IP Control.
Thanks for the pointer Will.


It wont turn on
At least not my Europen model 203 with latest firmware. Network standby is on, ip control on.

Once I turn it on with the remote everything works with simple control

So the problem still remains, how do I power it on by simple control

I am so sorry to bother you, this has been a problem since I got it in April 2007, I am unable to solve this by my self.

Resurrecting this thread. I just received an Oppo UDP203 for Christmas. It is running the latest firmware. Simple Control had no problem finding and adding it as IP controlled device (Oppe 103/105). As mentioned above, it will not power on the device however. It operates all the other functions, including power off. Setup Standby mode is set to Standby Mode as mentioned above.

Any further suggestions?

UPDATE: I see there is a UDP 203/205 available when configured manually. Configured with port 23, it now functions with power ON. I’m not certain why it defaults to 103/105 with auto discovery, but glad to have it working properly.

I think this discovery mismatch happens if someone manually renames their Oppo in the firmware screens which ends up overwriting the model number in discovery. It’s so rare we haven’t looked into it, but yes that would be the solution.