Panasonic 2012 gt50


Love the roomie remote, I’m changing from a harmony link. I have one question so far, how do I get my 2012 panny to turn on using ip control? I have the wake on LAN turned on in the TV menu, I’ve read the FAQ but I’m missing something. Thanks

I’ve entered the MAC address manually and the TV still doesn’t power on or off using wake on LAN

Does it matter if my TV is accessed to my router wirelessly?

Remember that the MAC Address of the TV will be different on Wi-Fi versus Ethernet. It’s likely the MAC from auto-discovery is only applicable on Ethernet so you may need to enter the Wi-Fi MAC. If discovered over Ethernet, there is no need to enter anything as the default MAC is used.

Thank you for the response, when I view the MAC address on the TV it only shows one MAC address, does not differ between wired or wireless. Still having issues

I have a VT50 and I struggled with this for awhile. I got it to work by ensuring that a wake-on-lan signal is actually being sent by roomie. In my case it didn’t do this automatically. In other words, “Power Toggle” and “wake on lan” are not the same thing. I never had to mess with MAC addresses. Screenshot:

I continue to have the same problem with my gt50. Have entered the Mac ID I got from the tv, have set WOL and added the command to Roomie to wake on LAN but the tv will not turn on. Everything else works fine. Im using wifi with a Harris router Any suggestions?

Try without the MAC address, it’s not always necessary and it’ll fail if it’s wrong. Then if you have to put it back double check to be certain that the MAC address you’re entering in Roomie corresponds to the correct interface on the TV (that is, wifi or ethernet depending on which one you’re using).

Good luck, hope that helps.

I’m having the same issue with my 2012 vt50. I’ve tried with and without the MAC address and have added the WOL command to the activity. I am connecting to the LAN wirelessly. I wonder if that is the problem? No problem controlling the TV once it is on.

For now, I’m able to get the vt50 turned on using HDMI control through my Yamaha receiver. It is an ok work-around but I’d like to figure out the WOL option if possible.

Thanks in advance for any suggestions.


Per prior message, yes the issue there is the Wi-Fi MAC. The TV only reports its wired Ethernet MAC to us. Therefore, you need to enter the correct MAC manually into the +WAKE ON LAN command in the correct format. The correct format is shown in the field before you type it in.

If the Mac I get from the menu on the tv is Ethernet and I’m only using wifi how do I get the wifi Mac to use? This should not be so complicated.

Still no luck with my vt50. I double checked my router and confirmed that the MAC address shown on the TV is the correct one. Then I entered it in the WOL command using the format shown. I have the latest software update installed on the TV. Any other suggestions?

Given the variability with WoL and European models, one possibility is that Panasonic didn’t enable WoL via Wi-Fi on some models. We’d recommend using Ethernet instead.

No ethernet cable in the room so that’s not an option.

Can confirm my vt50 works over Ethernet, powers on using the WOL command


Did not work over wifi