Pioneer VSX-1020-K IP

I had to add my vsx-1020 via manual IP as opposed to auto-discovery? Is this normal? Control was spotty at best so it appears only one connection is allowed at a time, can someone confirm this?

Power Off of the device would work but Power On will not, is this a problem or normal for the VSX-1020?



Pioneer receivers definitely are single-connection. The only way around that with Pioneer is to go with serial control but that model doesn’t look like a serial model.

The power issue however is just a setting on the receiver:

Thanks. I did see the network standby info in the FAQ, however, I did not see that in the menu system on the receiver. I will look again.

Another thing I noticed when I would select Add Device and it would start scanning the network for devices if the receiver was on, it would power cycle the receiver. After that the receiver would have to be reset in order for roomie to be able to control it after adding via Manual IP.

You will find numerous references to the crashes in that model in the forums here. It afflicts most/all of the 2010 models from Pioneer. We have not seen any reports of it in their 2011 and 2012 models. Just putting the 2010 model on the same network as a Yamaha receiver causes it to crash in seconds (among innumerable other ways to engage the crash). There is a major firmware bug there, and it’s next to impossible to get the firmware fix. Apparently it requires sending the unit to one of a handful of service centers, but that first requires convincing Pioneer to take it.

Thanks for this info, much appreciated. Very frustrated that Pioneer didn’t support network firmware updates. I actually have a VSX-1121-K that I recently acquired so I think I will replace this 1020 with that and hopefully that will resolve the main issues. Think I will move away from Pioneer if they don’t support firmware upgrades over IP.

I also did a search and can’t find anyone who has been able to turn this receiver on over IP even with their own control app and I am sure there was not a network standby option in the menu.

I’ve had success with my 1020. Before powering off turn zone 2 on.

Create another 1020 but zone 2

i have no problem powering it on for use later

Thanks thruster, I will give this a try!