Plex app IP control on the Nvidia Shield

I remember this being an issue, but now have noticed the Plex app is official listed as compatible on the Nvidia Shield.

That being said, I can get it to work no matter what I do.

It is discoverable, but when I add it to devices it has no response. I have no issue controlling the Shield itself or Kodi thru ip, but no luck on the official Plex app.

Am I missing something?

While you appear to add Plex Media Player directly, commands actually go to your Plex Media Server which controls all players. So making sure every aspect of your Plex config is correct including your server, your Plex subscription, your Plex login, etc. are the factors involved, all of which are on the Plex side.

OK thanks. I’ll look into it and make sure everything is set up correctly.

I’m guessing that the shield is more sensitive to those configurations than Apple? I have no trouble controlling the Plex app on the Apple TV.

I know this was broken for a long time but seems now it should be working.
just curious did you even get this working.

despite my best attempts I have not bel able to get Plex player to work on shield.
Like you I can ip control the shield but no luck with Plex or the media guide.

I have checked all the settings I can think of on the server and everything seems to be set up as expected.

I wish i had better news for you, but could never get it running. Will keeps saying it works, but I don’t think it does.

In fact, as a result, I sold the Shield and picked up a Zidoo Z9X (use the Apple tv and Infuse Pro for everything else).

Good luck


I am not quite ready to give up on the shield just yet.

@Will_Price is there any specific setup guides for getting this to work. I have covered off most everything I can think of thus far.
I can confirm looking at the logs on the Shield plex media player that the command is making it to the player ok but from there it is not translating to any movement on screen.

Here is an extract from the log on the Plex media player. this is coming from my IOS device running roomie to shield plex media player
12-11 17:05:43.478 i: [HttpServer] / - GET /player/navigation/moveUp
12-11 17:05:43.661 i: [HttpServer] / - GET /player/navigation/moveUp
12-11 17:05:43.794 i: [HttpServer] / - GET /player/navigation/moveUp

Quite possible they broke something. Posting it only in the forums with no ticket is a good way to make sure we won’t notice. If you have a problem with something that worked and should still be working, submit a ticket. Not clear if your issue is starting content via media guide or cursor control. They are completely different in the Plex world. Anyway, this is going to go in circles in the forum where there is no ability to analyze properly. Ticket. Diagnostic.

yep had planned to submit a ticket later today… but never hurts to post in the forum as well for the benefit of other users. :grinning:

Still no ticket, so just based on our quick look, we fixed some issues based on some changes they just made. However, I think there are still issues if you enable their 2FA support, make sure that is turned off. So first wait for 8.1.4 or 8.2.0 whichever is the next release then try again. Or, the fix we just made will also be in 8.2.0 betas shortly. Of course, since there’s no ticket here, this could all have no application to you at all.

Hey will.
I totally got side tracked and then Xmas…kids… and life just got in the way… blaa blaaa. And I just never found time to get back to trying to get this working… sorry mate.

I have got 8.3 (2614) running and I hope to have some time to try this again over the Easter break. I know you did a lot of work with Plex. As suggested I will remove the devices and set them all up again.

I will let you know how it goes.