Powering on Sony TV using network control

Hi, hope someone can help…

I have three Sony TVs :wink:
On one (XBR-65X900C), all works, I have full control via IP.

On the other two, I’m unable to turn them on using power on IP command.
The two are Sony KDL-50W808C and Sony KDL-75W855C.
In the TV, I set remote start to On in the network settings.
Added a Sony all models as a device in Simple control.
Change the interval to 500 or 1000 ms.
All commands works, only the power on is not working.

Any idea what can be done here?
(I’m already using itach IR, but this is lame…)


You didn’t say you added a +WAKE ON LAN command. Also, make sure to check those W models against the compatibility list. Many W models were not Wake on LAN models.

Thank you.

Hi Will, thanks fo r the help. I have added +WAKE ON LAN with the relevant MAC address. Did not help.
Something strange though. On one TV, the Sony KDL-75W855C, I’m able to start the TV, using the test remote screen from the device. The same commands (power on or power toggle) do not work inside a script…
Regarding the compatibility, it indicate that 2015 models should work with wake on LAN…


The Test Remote screen bypasses Power Tracking and just acts like a raw remote. So it sounds like you want to turn off Track Power State for that device. In general, Power On does nothing for Sony TVs as they’ve been either Wake on LAN or nothing for a few years. The most common issue is using the wrong MAC address for devices that use both Wi-Fi and Ethernet.

Thank you.

“The same commands (power on or power toggle) do not work inside a script…”

I have a very similar problem with my XBR-65X850C, but with a twist. The “Power On” and “Power Off” commands do work properly within scripts for a time. Then something causes those commands to stop working within scripts, but they still work in the Test Remote feature.

So far the only fix I’ve been able to figure out is to completely remove the TV device from the app, re-add the device, then re-add the commands to the scripts. This is really annoying to do every time the power commands stop working though.

I do not know what specifically causes the power commands to stop working within scripts but, on average, I’d say it happens every couple weeks. Not sure if it’s relevant but I have multiple iOS devices with the app installed.

The Android based Sony TVs lose the network connection after a few days of inactivity. l had to go back on three installations to IR.

I don’t think there’s any problem that generic with Sony TVs. We have numerous Sony Android TVs used for testing and do not observe that behavior.

There is a cookie lifetime of 2 weeks for Sony TVs. If you don’t use it for more than 2 weeks, you might experience a moment where it needs a second power command. They do not actually shut down their network interface unless the settings on the TV are not properly configured for quickstart/etc to keep the TV listening on the network. By default, they are set to do what you describe. Make sure to configure the TV correctly.

Thank you.

Good to find your posting. I have exactly the same issue -works for awhile then not, and the test remote works all the time. Did you ever find a fix for this, other than reentering the Sony device?

Worst case scenario here was never more than issuing an extra command. Re-adding the device would certainly be overkill.

BTW V5 does tighten this up.

Will, I’ve tried adding an extra command, even playing with the timing to make sure it’s received, but deleting and adding the device is the only thing that works. Applying this to one iPad does fix the problem for the other IOS devices though. What else is different about sending power commands from the script vs. the Test command other than the power state tracking?

At this point it’s been so long since I’ve used 4.5 and we made changes here in V5 which is right around the corner. Try sending a REGISTER command from the Virtual Remote. That should force the process of refreshing.

This one is so frustrating…
I’m not sure if the following fixed the problem in my case, but for the past weeks, the problem didn’t occur…
What I did, is to switch from LAN to Wifi…
(though had a cable just next to the TV, and was using the correct MAC and IP of the LAN card)

OK, I’ll try that when it happens again. Looking forward to trying V5. Thanks.

Strangely enough the problem eventually seemed to fix itself. There have been multiple software updates on the TV since February, and I believe multiple updates to the iOS app, so maybe one of those solved the issue.

You’re lucky. I have two TVs for which I have the problem. Fortunately, Will’s suggestion to send a register command temporarily fixes it (until v5 comes out, I hope).

The Register command worked perfectly. Any issue with sending that in a script every time?