Primary Controller Relay Port

I am moving to a new network config and when using the VPN for Roomie access, I need to create port forwards. Old VPN and network config worked fine so I know this is down to ports and the primary controller relay.

I have all of the direct control devices working with a port forward such as Directv (port 8080) and AppleTV (port 52383), but need some help for my Denon receiver that is connected via an ip2sl rs232 and using the relay function at the Primary Controller.

I am assuming that when using the Roomie app (VPN-to-LAN or LAN), it is sending each message to the Primary Controller (iPad - which then relays that message to the Denon ip2sl rs232 device at

My question is, what port is the Roomie app using to send the relay request to the Primary Controller from the device I am using? I have tried 80, 443, and 4999 with no success.

Thanks for any insight.

Without commenting on the concept, the simple answer is that such internal messages are sent over UDP 47148.

Thanks Will for the quick insight. Was hoping that would be it but no luck. I know it is an odd setup right now so appreciate your response.

I also tried turning off the Relay function since this Denon is being controlled through RS232. I assume with that turned off, Roomie should be sending out a message direct to similar to what it is doing for Directv at 8080. But even with that, this is the only device that does not connect which seems even more odd.

This device is working fine on the local LAN connected devices and is accessible via the VPN and forwards though its port 80 web interface and other devices with odd ports such as 4997 are working too through the VPN. I am guessing now it is something with this specific device but that seems off considering all other devices not using Relay work through the VPN and it works on the local LAN too.

Time for more digging.