Problem Controlling Fire TV 4K

I have both a Fire TV Stick and a Fire TV 4K, both the latest models from Amazon. The Stick works with Simple Control perfectly but I cannot get the 4K to work at all. It is auto-discovered by the app without any issues (and I’ve also tried manually adding it) but it cannot be controlled. ADB is enabled. I’ve tested it using the Android Tools for Linux running on a Raspberry Pi and both Fire TV models are controllable using the command line eg:

adb start server
adb connect
adb shell input keyevent 20
adb disconnect
adb kill-server

Any ideas why the Stick works but not the 4K and what I can try next?


Since nobody has reported an issue with that model, and I have one here and it works fine, I’m more inclined to think this would be connection related. ADB has issues with more than one device connecting. Be sure every Simple Control instance is shut down along with anything else that may attempt to connect to that device. Then power cycle your iOS device (which also helps ensure you don’t have other errant apps trying to connect to it) and then connect.

I can’t get things working with only a single IOS device powered on either. I also tried running two instances of the linux command line tool and can see the issue when attempting to connect from more than one device and can successfully flip/flop between the active connections from linux with the adb disconnect ipaddress command. So I’m fairly confident multiple connections aren’t the issue.

What I did notice however, is on the very first attempt to connect from Linux or the Amazon Fire TV app, the Fire 4K prompts me to enter a PIN. It does not prompt me for a PIN when attempting to connect from Simple Control. The FireStick has never prompted me for a pin from any connection method. Don’t know if this means anything.


Unless you’re going to WireShark it, that’s about all that could be done in a forum environment. Support can diagnose these things easily.

Happy to Wireshark it and/or open a support ticket. :slight_smile:

I opened a ticket with support and got their out of office notification saying that they are closed until Jan 16 :frowning:

So Wireshark it is… Before starting, I factory reset both the 4K and the stick.

Stick OS is v5.2.6.1 (587601020)
4K OS is v (NS6212/918)

Wireshark captures from both my iPhone running SimpleControl 5.0.8 and my Raspberry Pi using the Linux ADB tool, yield near identical results. Both methods successfully control the stick. There is no pop up asking me to “Allow USB debugging.” I see the iPhone send the CNXN command, an ack from the stick and then the SHELL INPUT KEYEVENT command. All is good.

However, when I look at the Wireshark captures from the 4k, there are differences. When I run the ‘adb connect’ command from the Raspberry Pi, the 4K immediately pops up a dialog box asking me to “Allow USB debugging.” Until I click accept using the FireTV bluetooth remote, all further commands from the Raspberry Pi are ignored. Once I accept, the 4k sends a packet to the Pi containing the CNXN command with some extra data containing device information. After this, all further commands from the Pi are accepted.

When I connect to the 4k from Simple Control, I see the exact same CNXN command (43 4e 58 4e 00 00 00 01 00 10 00 00 07 00 00 00 32 02 00 00 bc b1 a7 b1 68 6f 73 74 3a 3a 00) but I do not get the pop up. Subsequent commands are ignored.

My best guess is that because Simple Control is sending the SHELL command only a couple of milliseconds after sending the CNXN commands, this is somehow affecting the pop up, preventing it from displaying. Because I can’t type that fast on the Raspberry Pi, there is sufficient gap between the commands that the pop up is displayed and I get the opportunity to acknowledge it.

What version of Fire OS are you running on your Fire TV 4k?


Just to confirm I’m having the same problem with the new Fire TV 4K (2017) model. Auto discovers device but not controllable. I first noticed this issue about a week ago (ish) but assumed it was something at my end so didn’t raise it as was going to have a look when I had more time.

Definitely not something at my end - I have a Fire TV stick (newer model) and the original Fire TV 4K box and they still work perfectly.

It was either a recent update to the Fire TV 4K device (last updated 18/12/2017 to Fire OS NS6212/918) or the recent (not today’s) Simple Control update. I’m more inclined to think it will be the Fire TV update.

I can raise via support but as I’m not the only one, thought I’d mention here as might be a bigger problem than just one or two users…

Not sure why I thought there was a Simple Control update today - must have been confusing it with another app…

The issue doesn’t appear to relate to the PIN requirement that David mentioned as the Fire TV stick requires that when using the Fire TV remote app, but Simple Control still controls it without issue.

Is this the brand new Fire TV 4K? The small one with the HDMI attached? I am having the same problems with this version.

Fixed the auto-reply to say Jan 2, next Tuesday.

Anyway, we’ll take a look at it next week. Hopefully someone actually filed a support ticket.

Yes, I filed a ticket.

Glad it is not just me :smiley:

This has been resolved in 5.0.9. It will go to the App Store after some beta testing, review, etc.

This issue should apply only to the very newest Fire TV 4K full size model. But in principle in the event Amazon changes the firmware for any others, we will recognize the change automatically.

Good news, thanks! Happy New Year!