Raspberry Pi - 12.0 Frodo XBMC

I’m having trouble getting the XBMC Roomie controls to work with this setup

I’ve tried the Media and the JSON options and both do not work

The port and IP settings are correct as I can access and control it from a webpage

I can also control it from a 3rd Party XBMC controller as well

Any idea what might be causing this issue?


Same issue here under Windows.

There is no relation between “I can control it from a webpage” and “I can control it with Roomie”. In fact, those are almost always different ports so equating them implies a misconfiguration.

By default, Frodo’s JSON control runs on port 9090. Make sure to use that port and then select the XBMC JSON interface in Roomie? The old HTTP interface was removed from Frodo+.

I’ve added the server to Roomie now with Port 9090 and JSON

And it does one command then freezes the application.

I’ve tested it on an Iphone, Ipad and Ipod Touch

Connected to two different 12.0 Frodo installations

What could be wrong?

Well when I say freezes the application… It wait’s about 20 seconds trying to send the command. Then it flashes the command I tried to do in Red like it didn’t go through properly

Same here, about 15 secs before I can send a new command.

Red means the port is not open basically. So the XBMC install has some kind of configuration issue that is not accepting commands.

These are just basic installations.

They do not have iptables running so there is no chance that port 9090 is blocked that way

My router is using DD-WRT but all the devices are inside the same network

tcp 0 0* LISTEN 1953/xbmc.bin

This is an output from netstat on the device

Port is open waiting for connections

Also as chicabou said

The command actually works… it just takes 15-20 seconds to allow you to make another command.

There is a wait icon next to wifi symbol up on the top left of the device

When that stops you can do another command

Support will need to see a diagnostics run on that connection to determine what might be wrong. They can be contacted at support@roomieremote.com. Basically just turn on Collect Diagnostics, perform the action that exhibits the problem a couple of times and then tap Send Diagnostics and turn off Collect Diagnostics. Then email support with the time at which it was sent.

I have collected the data and sent it to support@roomieremote.com

At approx 11:53 AEST


This is fixed in the new library update that just went live.

I’ve updated the Library and tried on both machines

It’s not working at all now

I’ve uploaded some more diagnostics at 5:55pm AEST


Looks unrelated. Your XBMC isn’t answering the connection at all. We’d recommend restarting it and your iOS device.

Ok so I’ve tried using my Ipad, Ipod Touch and Iphone on 3 different installations of XBMC

2 on my Raspberry Pi (Xbian and Raspbmc)

And normal 12.0 installation on my desktop

I’ve restarted and reinstalled my Roomie installations

I’ve also rebuilt new XBMC builds…


It’s the port. Just remove the device and re-add it on port 80 instead of 9090. Apparently 9090 is for a raw JSON connection rather than the normal JSON control. We just setup Frodo Beta 1 and it is working with port 80.

Working perfectly on port 80

Thanks for the help