Resolution for 1.8.1 Crash on Open

1.8.1 has a problem where, once you crash for some reason in Roomie, which hopefully never happens but let’s just say it did, you will always crash, immediately, on open.

This problem is however easy to resolve. These steps cure the issue altogether so it wont happen again.

  1. Turn on Airplane Mode and/or turn off all networking.
  2. Run Roomie 1.8.1 (this wont crash because networking is off)
  3. Turn off “Auto-Update Devices” in Roomie’s Settings.
  4. Turn off Airplane Mode and everything should work fine now. If you crash again later for some reason, the same problem will not re-occur.

We have just sent 1.8.2 to Apple. After 1.8.2 is out, you would usually want to re-enable Auto-Update Devices.

We apologize for the inconvenience if you run into this issue. We were trying to tighten up our crash reporting to eliminate some of the more obscure issues and, well, it’s safe to say we tightened it up a bit too far.

Also mashing the app icon repeatedly like an insane person may work, as in my case :slight_smile:

Unsticking this post as this issue was resolved by version 1.8.2 that is now available.