RS-232 to Somfy Shades

Hi guys,

I’m trying to get my Somfy Shades to work on Serial 2 on my GC-100-12, and nothing seems to get through.
When I use iTest (from GlobalCache), the commands I need to send (0101U, 0101D and 0101S) work just fine (both in ASCII and in HEX [30 31 30 31 55, 30 31 30 31 44 and 30 31 30 31 53 respectively]) but using RoomieCodes.plist does not seem to work no matter what I try.

I’ve put the file here:

As mentioned, I’ve tried plain text and HEX, as well as each one of these as binary, lineio and lineio-crlf.
The device that sends the commands is a Somfy URTSI-II ( and I know it works because iTest moves my shades without fail.

If anybody can point me in the right direction, that would be greatly appreciated.



If you take a look at the DDK here:

Take a look at the Serial examples. You are entering ASCII data as if it is binary:


That’s not what the examples do. The simplest thing to do is probably just to change to:


You’ve also specified “lineio” as the method, but it looks like this is a binary protocol without any CRLF type line IO. So you would want to specify “binary” for that.

(Replace all “.” above with greater than less than signs as appropriate.)

That worked like a charm, and makes perfect sense when I think about it.
As for the lineio, it was still set from all the testing, but you were correct, it works on binary.



You can help me and give me as definitely was the file, since I have tried all methods and can not run.
I am using same Somfy URSTI II, and GC-100-06.
Thank you for your support.

You’re using this file as a test file correct? … omfy.plist
Did you rename it as RoomieCodes.plist, and restore it from dropboxthe way the customDevice FAQ (linked above by Roomie) describes?
If so, you should see 1 custom device under the main settings.
Based on this plist file, I have set it up to be under Auxilary devices, so it should work.

Did you test the URTSI-II with iTest (from GlobalCache’s website)?

Thank you for your attention.
I already copied the new Roomiecode.plist and neither worked.
I just did the test with itest, sending the code 0101D but does not respond. I indicated in AscII “unknowncommand.14.” (command not supported). Which can it be my problem.?

Best regards

Let’s start narrowing things down.
You can control your shades using the buttons on the URTSI-II, correct?
The URTSI is essentially a remote, but the channels do have to be copied over from the regular remote to the channels on this device.

If this part works, then on iTest, connect to the serial on the GC100 to send the signals (not the IR side, since that won’t work) and then the codes (0101D) should work. The URTSI-II should be set to channel 1 when connected though (don’t ask me why).

Thank you for your attention.
URTSI-II works well. All codes per channel have already been copied. I currently have it connected to a URC MSC-400 by Rs-232 and it works perfectly. I want to change to Roomie, but I find problems to set up my lights and blinds. Test Itest with the Somfy connected by rs232 (0101U, or 0101D), says “command Not Supported”.
All instructions that tells me, have already been tested. Will the GC-100-06 be faulty or unsupported?

Best regards

Just to be sure, you are choosing “Serial 1” when connecting through iTest, correct? (Command is for sending IR signals only).
When I connect to my second Serial that does not have the URTSI-II (I have a GC100-12, so 2 serial ports) and send 0101D, it doesn’t give me an error, it just doesn’t give a response, which is why I think maybe you are using the wrong connection to run the test.

Otherwise, perhaps you need a null modem attached to your RS232 cable (different devices need the cables to be pinned differently)

The GC100-06 (as per is definitely supported, but it does require firmware 3.0 or higher.
It could be faulty, I’m honestly not ruling anything out, perhaps Global Cache can be of help figuring that out.

Thank you for your patience.
I did the I-Test by the serial 1 and already not it failed me. The display shows:
Command String. 0101D
Last Command Sent: 0101D
ASCII Response: blank or nothing
Hex Format responsible: blank or nothing.
I have it the connection with a null modem (I think), through a coupling for RJ-45. The persionas are not activated. Can it be the connection? Like you connecting the GC-100 to URSTI.?

Best regards

It could be the connection. The ASCII Response in this case should be the same as your command, and it should fill out the HEX Format also (in case of 0101U this would be 30 31 30 31 55)

The trick is to figure out which pins to connect when going from RJ45 to DB9. I have it written down somewhere, but it’s been 3 years since I connected mine originally. I’ll try and find it when I get home.

However, since it already worked for you on your URC MSC-400, it seems the cable is OK generally. You might still need something like this: … 1&format=2 to properly convert the signal though, since there’s 2 ways of wiring the cable depending on the hardware you connect it to.

Really I appreciate all your support. I’m going to try to get the wires allowing me a correct connection. I live in Mexico City, and here is a little difficult to find those accessories. If you have any other suggestions, in advance will thank you. I think that my Lutron Homeworks 4 teams do not work for this.

Thank you.

No problem, I know how frustrating it can be trying to get this to work.
What I found in my old backups is that the following pins are the ones that are used on the DB9:
Somfy Pins:
3 = Transmit
6 = Receive
7 = Common
8 = Common

However, I can’t remember if transmit goes into receive on the other end and vice-versa. I would test the individual pins before committing them, just be carefull not to short the USRTI-II.

As far as the Lutron, it should as long as you know the commands to send, but it might have a similar send/receive reversal problem. See online if you can find what the ASCI or HEX codes would be.

I did it I-Test for serial 1 for Lutron, and as no error, but there was no response in the ASCII or Hex format. I’m going to get the “Mini Gender Changer”, to see if I can at least find an O.K. communication. Do you think that can solve it?.

Best regards.

It’s not really a gender changer. It just sounds like you’re not getting proper handshaking between the GC100-06 and your other devices, which a null modem will hopefully fix since it’ll cross-link the wires.

Remember in the old days ('90s), you had to think about needing a cross-linked or straight ethernet cable depending on if you went directly between two computers or between a computer and a router? Similar concept. I’m not an expert though, so again the guys at might be able to provide better/clearer help.

Transmit should go to receive. Please only use the pin 7 ground for 232. Also please make certain your rotary dial is set to “1” when using the command structure 0101U.

Support for Somfy RS-232 will be in the next library update with an official command set from us. Note that the user command set in this thread requires manual editing of the set for each installation. The official set will instead use Roomie parameters. So you will specify for instance “05” as the parameter in order to send “0105U” using a .SHADE UP command. The parameter is the channel.

I have a Somfy URTSI-II controller for motorized window shades. To control it from the Roomie app, can you confirm that all I would need is a Global Cache IP2SL on my network, and plug in a RS-232 cable to the URTSI-II? … apter.html

Yes, that’s correct.

The IP2SL or the iTach Flex with Flex Serial Cable would be the choice there. The URTSII also usually has a custom RS232 wiring adapter that you attach to the URTS side of the cable.

Thank you.

Having trouble with Roomie, IP2SL, and URTSI-II. I can raise & lower the shades with the buttons on the URTSI-II but not through the IP2SL. Maybe I messed up somewhere? Here’s what I did.

1) Hooked up the IP2SL to my LAN, went to its IP_ADDRESS, and changed the serial port configuration to 9600 baud, 8 data bits, 1 stop bit, no parity.

  1. Set up the URTSI-II with 4 Somfy motorized shades. I can select channel 1, 2, 3, or 4 then press the UP and DOWN buttons on the URTSI-II device, and it does raise & lower the shades.

  2. Using the serial adapter included with the URTSI-II, I plugged in the DB9 female side of the adapter to the DB9 male serial port on the IP2SL. Then plugged in a ethernet Cat-6 cable from the adapter to the RS-232 port on the URTSI-II.

  3. In Roomie, I added the IP2SL device by choosing Add Device, selecting the Global Cache iTachIP2SL, Port as Serial 1, Type as Auxiliary, then Somfy.

  4. Set up an Activity in Roomie with the command “.SHADE UP”, Somfy ID “04” (for channel 4), but nothing happens. Tried other channels, also tried “.SHADE DOWN” but none work.

Any thoughts?