Setting up AppleTV 4K as primary controller

Can someone supply the steps required to use an ATV 4K (2021) as the primary controller running tvOS 15? I am currently using an iPad as the primary but it is constantly being left off the charger, running out of battery, and then the controllers in other rooms stop working. I plan to place this ATV in my equipment rack where no one will have access, it will be hardwired to power and ethernet, etc. So no chance for failure. But I don’t see any way to put the AppleTV into Guided Access mode. The instructions in the user guide are for iOS and I need something for a tvOS device.

If I remember correctly, you can set up Apple TV in Kiosk mode. You can find the steps to do that on the internet.

It’s called “Single App Mode” and it’s part of Apple’s SDM.

I have not heard a lot of positive comments about that from users, so I might recommend just skipping it and making sure “Sleep After” is set to Never and see how it goes.

I maintain that a current model iPad on a charger in Guided Access definitely remains the best choice for a primary on many metrics. If you have a problem with people removing the iPad from the charger, that is a personnel problem that should either be solved by discipline or a separate iPad.

I followed an article from Kitcast to set mine up and it was fairly easy, just replace their app with Roomie. Here is link:

Thanks, netcam, that process worked. I have the latest version of Roomie 7.3 installed on my iPads. However, the version for tvOS15 is 7.2. When I installed that version of Roomie, it doesn’t connect or see my “named” home, so it only shows a default “home” to select. When I tried to point at the Apple TV device as the new Primary from one of my iPads, the Apple TV shows up but is greyed out in the selection list. I can still select it and it will show on the Homes screen as the new Primary but the Roomie app on my Apple TV is not connected to the same Home, so it doesn’t work. I’ve tried both ways of having my iPads all pointing at the current Primary (which is another iPad in Single Access mode) or turning off that iPad completely and pointing all the others to None as the Primary before I install Roomie on the Apple TV. Neither method worked.

So my questions are when installing the Apple TV Roomie 1) can I run 7.2 on the Apple TV and 7.3 on my iPads, and 2) how to I get Roomie on the Apple TV to “see” the “named” Home so it can connect with the rest of the devices and be used as the Primary?

7.3 beta (which should only be discussed in the beta forum or direct tickets) will work fine with any 7.2. I would uninstall the app on your ATV, restart ATV, and then re-install to re-load your iCloud stuff. Make sure it works perfectly before trying SAM.

Thanks, that did the trick. All working now.