Simplified VPN setup

I have my own on-site VPN that I use to access security cameras. In the past I was also able to open Roomie Remote and control my entertainment system. I not sure when it changed as I did not use it often, however I now have an elderly parent that calls me to raise the volume when I’m not near enough to connect to my LAN.
So, do I forward port x to port y on my router? Maybe somehow that’s changed? If so what are the value of ports x & y?
Does each device need their ports forwarded?
All help is appreciated.
Roomie Remote Ver 8.7.0 (2784)
iPhone 12 Pro max
LPT2 VPN server


Roomie has no direct interaction with a VPN. Properly setup (which really just means a working VPN, there is no special magic I’ve ever heard about or used) VPN will pass Roomie traffic just fine, no port forwarding needed. The standard iPhone L2TP for example is what I use and it works well (to the Sonicwall L2TP server in my case).

I haven’t figured it out either. I’ve tried multiple VPN configs (L2TP, WireGuard, OpenVPN) on a UDM Pro with little success. At times I would be able to control FireTV and Roku devices but unable to run activities and control other devices such as TVs and Receivers. I had opened a case but there was nothing specific they could provide. Would be nice to get a feel for how many other users are in the same situation and how many have no issues with VPN into Roomie :slight_smile:

Thanks Will. More investigation on my side then. My VPN accesses my security cameras fine. I used to be able to run Roomie Remote, so I’ll keep trying.

Hi Will,
I had my iPhone set to WiFi calling on, so I disabled that feature and started my VPN connection again. I can now control my entertainment system over cellular. Apparently the Xfinity WiFi calling wasn’t passing the Roomie commands. Though, like I mentioned, I could access my security cameras and hear the audio and control the PTZ.

Well, that didn’t work either. The work around was to use my SmartThings App and control the volume through my Samsung TV using my VPN connection. That was successfully tested today while I was actual off my property and had to raise the volume for my 92 yo mother. It would be nice to be able to figure out how to get RR to work like it used to.

Since it works for us and many others, you would want to look at your VPN settings to debug that. Clearly, some kind of traffic is getting mangled by your VPN.

Ok Will, I think I found my problem. In Roomie>Devices, 2 of my devices (Onkyo AV Receiver & Samsung TV)>Show Advanced there is the option to ‘Disable Relay’ it was off and I turned it on for the 2 devices. They now work flawlessly. I’ll review the other devices that are rarely, if ever, used and see if they have the same option and change the setting as needed.
Thanks for your time.
I hope this helps solve a problem for others.

Thanks @Diveboss

Based on your findings I’m getting closer to resolving my Roomie access via VPN. I set the option to “Disable Relay” on one of the devices to test and now that device works. I’m surprised at that option for VPN, I would think VPN would want to rely on the relay versus having to touch every device. It seems that’s why my IR devices worked and IP devices did not.

So, if that changes anything for you, again I return to what I said before, “some kind of traffic is getting mangled by your VPN.”. In this case, the UDP 47147 or 47148 port traffic is being affected by whatever your VPN is doing. That’s the only protocol/port ever used between a client and the primary to relay traffic.