Somfy MyLink integration with SC

I just bought about 20 shades thru Somfy and was wondering about integration, I read that I would need the Universal URTS controller to make it work however they now also have a new app with a small bridge called MyLink…would that also work?

The URTS II is their serial controller, we do have a codeset for that.

Despite constant contacts going back years, Somfy has refused to release an IP control protocol so they’re basically incompatible with integration via IP. You may want to encourage them to do so, you wont be the first. Serial remains the best option for now.

Thanks for the reply…They must have an IP protocol since the new MyLink app can now be controlled using Amazon Alexa,so i can voice command the shades.

Is the IP protocol something that Somfy has to give you or can it be figured out once they have a device?

They do, they just don’t publish it. We do have leads now and so it’s possible in the future. But we have been trying to extract these teeth for several years so we’ll see.

1 Like

Thanks Will, i guess i should call and write to them so they can perhaps be convinced to join the digital revolution.

Here’s the link to the spec sheet which indicates that they now have integration with third party apps over IP.

Yes, Somfy appear to be sharing their IP control codes.
I also use a bridge called MyLink.
When will the codes be available in SC?

Fredi, I spoke to someone at Somfy and they said that they would make this available upon request.
My device list is increasing every week (i have over 60 devices) and at this point i’m not investing time or money into any solution unless it will control everything…once Somfy gets added to Simple Control…that’s when I will buy into it…however i’m also still on the fence about going with Control 4…but the app has terrible ratings.

There is no debate this information is now available. We have the info. We are just waiting on test hardware from Somfy.

1 Like

That’s great, cant wait.
If you guys every release beta versions for testing I’d be glad to help out.

I am trying to setup Somfy control through a new MyLink but am not having any success. I’m doing a manual device setup, using the correct IP address on port 44100 and have tried every variant of what might be the network identifier. I think this must be what I’m missing but for the life of me I can’t get it to work. I see Shade 1 - 16 up/down available under commands but it’s not moving the shades. The light on the mylink normally flashes red when I control the shades through the Somfy app. I get nothing when trying to do it through SC.

I’ve tried the following for network identifier:

under INFO
Base Address
Mac Address

Under Integration
I must select something like Control4, Crestron, etc. then Current System ID is not set. So, I set it. Still nothing.

Anyone know what I’m doing wrong?


Nevermind, I figure it out. I was adding the device as AUX because I found somfy there. I read the compatibility matrix a little more closely and see you need to add the device as Automation. Now it works. The only issue is all my shades show up as Unnamed when I add commands. Definitely not the end of the world.

You can name them in the manifest editor for the device.

Awesome! Thanks Will!

What did you use for your Network ID here. I can’t get mine to synchronize.


Hi, I too struggled with this. Here’s what I did:

Go into the MyLink app and go to settings/info.
Then select your MyLink Device. The very first line labeled ID: is what you want.

This next part is what took me so long to figure out and is what I had to do to get this to work.

In the MyLink app, under settings, go to integration. Select Control4. Set the Current System ID to the ID of the MyLink Device. While you’re here take note of the IP address as you’ll use that to setup Roomie.

I don’t know why but this seems to be what’s required for MyLink to allow Roomie/Simplecontrol to gain access to MyLink.

Next, go to Roomie and add your MyLink manually using the Ip Address of your MyLink and port 44100. Add it as Automation/Somfy. Also, enter the ID of the MyLink from above in the System ID Field on the device in Roomie. Now you should be able to see your shades when you click in the manifest link. You may have to select Update to get it to bring back the list.

One other thing to note… Mine just stopped working one day and it turned out that the Current System ID in the MyLink app was somehow deleted. I think it was after an update to the MyLink app.

Have fun!

Figured out the individual raise/lower/stop buttons though adding it as an “activity”.

Only way I could potentially automate it is to create an automation for every 30 min (ie 48 automations).

If you have any other ideas pls let me know.

So far I’m just happy it works!