Sony 55 inch 4K TV XBR55X850A

I just installed a new Sony 55 inch 4K TV XBR55X850A. I’ve been trying to get Roomie to power the TV on/off with custom buttons. I’ve set up three custom buttons, one with a power on command, another with power off command, and a third with power toggle command. The only one that works over IP is power off. I really want to be able to power on the TV if it’s been turned off, but I can’t seem to figure out how to do this. If the TV is off, it’s like it isn’t paying attention to the IP commands being sent to it. I thought this TV supported Wake on Lan - but maybe not. I just took delivery of it. Got any suggestions? Am I going to have to resort to IR to accomplish this function?

Wake on LAN commands are not the normal POWER ON/POWER OFF commands. They must be added separately as +WAKE ON LAN commands wherever needed. The FAQ shows how to do that:

An unrelated note with the 2013 models is make sure to hit the REGISTER command on the Virtual Remote as per the IP Compatibility page:

That enables all the special commands such as discrete input changing and many more because Sony’s registration process is now built-in.

Thank you.

Yes these TV’s do support Wake-on-LAN. You need to enable the option in the TV’s settings via: Home > Settings > Network > Home Network Setup > Remote Start > On.

i have a Sony 2013 KDL-65W850A that I cannot figure out how to get the Wake-on-LAN command to work. This TV was found by Roomies but it does not wake. I have turned the remote TV settings to on. I have also downloaded and used the Sony TV Sideview App. This app does turn tv on when used. However, I want a single app, single icon to turn on TV, Oppo 105 and Amp at same time. (using Denon receiver as my Amp) Only device that does not turn on is my TV. Of course they all do turn off… with that command.

Any one that has struggled with this and got it to work through Roomie App… your insights greatly appreciated. Thanks.

Generally, issues with that are caused by users trying to wake via Wi-Fi when the TV has reported an Ethernet MAC. To override that, enter the Wi-Fi MAC from the TV into the +WAKE ON LAN command. The next most common issue is that users do not use the correct format for entering the MAC Address into that command. Make sure to use exactly the format shown in the field as a placeholder when it is empty.

Thank you.

Thanks for that information. This is what worked for me with the Sony KDL-65W850A… made sure I used a MAC without any punctuation just the letters and numbers of the Address for Sony TV. Also I added after +WAKE ON LAN, additional comment of POWER ON. This seems to work, I am not adding repeat of those commands to make sure they 100% of the time. Also cannot seem to add these commands to a series of commands, like turn on TV, Turn on OPPO, and Turn on Receiver and Goto Netflix. But this is huge step forward that all commands now can be in my iPad. Thanks for your help, Roomie.