Sony BDP-S5100 Blu Ray

I purchased the Sony BDP-S5100 looking for some IP Wake on LAN integration. So everyone knows, there are a few issues:

  1. The compatibility page states Wake-On-Lan and indeed it does have this feature, however, it also states to register the unit with the free Sony Media Remote iOS app prior to use. Well, as of this posting, the BDP-S5100 is not compatible with the Sony Media Remote iOS app. SO… no Wake-On-Lan for this guy if registration is indeed required. I can confirm it is not waking on LAN for me but I do have some IP control once it is on.

  2. I do seem to be able to get some IP connectivity, however, is this unit a Series 8 or Series 9 or, instead, is there going to be a library update for the BDP-S5100? Which selection do I select?

  3. My work around is to IR blast power on. Once on I can IP the power off using Series 9 during setup. I have not tried other commands as of yet. Menu does work so I assume I get IP connectivity. Is there live feedback or is there supposed to be?

I assume at some point a firmware update will get the iOS app working and then Wake On Lan. I am more curious about feedback.


  1. Registering with Sony Media Remote is actually pretty much irrelevant on the 5100. Some of the new feedback depends on it, but you wont notice any real difference. Wake on LAN is not related. If that’s not working for you, you have a different issue. Perhaps you didn’t turn WoL on in the player menus. There are other threads on that topic that discuss the details for Sony players.

  2. It’s a series 10, which is currently the same as series 9 when selecting it.

Thank you.

Thank you. I now have this working. And it was stupid user error and I feel like a fool. Turns out I thought the regular ‘power’ button on the test remote would wake the unit when it was off. I now realize I must use the “wake on LAN” command as an action.

If others read this, entering the MAC address in the Wake On LAN action did not work. If the MAC address is left blank and you only use the Wake on LAN command it works (at least on the 5100).


You’re not alone. I couldn’t get wake on LAN (WOL) to work either until I read this post. So you have to select +wake on LAN when configuring a command in Roomie, you don’t use the regular power on command.

One strange thing I see is the wrong MAC address shown when I’m adding the +wake on LAN function. The WOL wasn’t working one time so during a troubleshoot I noticed the wrong MAC address was shown. However, the MAC shown in the device setup for the s5100 was correct. I tried adding a different MAC to the WOL function but it wouldn’t save it that way. The WOL started working again, not sure what the problem was the other day, everything still looks the same.

One additional comment on the S5100. It isn’t heavy enough. It’s so plastic and light that it moves around a lot when accessing the panel buttons, inserting or removing a disc or moving cables around.