Sony str-za810es receiver IP control working!


I’ve got a new Sony STR-ZA810ES. It supports IP control, but I can find no documentation anywhere on what ports it uses or what the setup settings mean. I nmpapped the device and see the following open ports:

80/tcp open http
5000/tcp open upnp
8008/tcp open http
8009/tcp open ajp13
10000/tcp open snet-sensor-mgmt
10001/tcp open scp-config
22222/tcp open unknown
33335/tcp open unknown
33336/tcp open unknown
50002/tcp open iiimsf
52323/tcp open unknown
54400/tcp open unknown
60151/tcp open unknown
64321/tcp open unknown

You’ll notice that manh are different from the ports that simplecontrol claims to support on sony es devices. SC says they support the str-dn810es. This is an str-za810es. They look identical but is there some difference?

Additionally there are a bunch of settings in the receiver setup that I can’t figure out what they do:

"Connection Server Settings"
There doesn’t seem to be anything I can “set”. It just says “Set whether to display connected servers” Serve name.
What are connected servers in this context???

"Auto Home Network Access Permissions"
This is set to on, but what does it do? Undocumented.

"Home Network Access Control"
There is a “controller name” for my sony bravia tv in here set to “allow” but I can’t do anything else in this screen to add simple control as a remote for the receiver.

Finally there is “registered remote devices”. It’s empty and I can’t seem to do anything to register a new device.

I contacted sony support, but they referred me to “ES support” and they don’t answer the phone. . I’ve been on hold for 50 minutes. There’s nobody there. I used to have a “premium” association with the sony brand but no more. I don’t even expect a business with customer service like that to be in business in 5 years.

Anybody know how I can register my simple control remote??

Oh last thing, I have this device wired. Does control only work over the wifi interface or something? I haven’t gotten a peep out of it on any port I’ve tried.

I finally talked to somebody at Sony who kind of knows whats going on, after nearly 9 calls and 2.5 hrs on hold. Sears Roebuck and Kmart have nothing on Sony in the “former glory circling the drain” department.

in short he told me that “IP support” in this device means this device uses CIS1 serial command set wrapped “over IP”. He said the command set on the STR-ZA810ES is identical to the STRDN1080. He also said that there’s no authentication needed, which I’m not sure that I believe.

After a bit of cajoling he provided some internal documentation of the command set, though I’ve yet to find any mention of the proper port. I’ve tried nearly every variation of model and port that I can think of with simple control with not even as much as a peep of response from the device, even though from the simple control side it looks like the commands are being sent properly.

The most notable thing about these docs is that they seem to have been created in the year 2000 and updated each model year since. Yep, Sony is selling a device with 17 year old technology in it and passing it off as “ip enabled”.

Then again simple control seems to claim that this device is supported, and provides 2-3 cryptic lines in a spreadsheet as their only documentation, which is equally appalling.

I mean look, below is what simple control has to offer by way of docs. Pretty much nonsensical. I’m slowly working my way through the matrix of every model type on every port number, but I’ve got nothing yet. Not even a peep back from the device.

Sony STR-ZA1100ES, STR-ZA2100ES, STR-ZA3100ES, STR-DN810ES, STR-DN1070 (2016)
STR-DN1060, STR-ZA5000ES (2015)
STR-ZA1000ES, STR-ZA2000ES, STR-ZA3000ES, STR-DN850, STR-DN1050 (2014)
STR-DN1040 (2013)
STR-DN1030, STR-DA1800, STR-DA2800, STR-DA5800 (2012)
DN1030 does not provide feedback.

Zones 1 and 2
Manual IP
Port 8080 (STR-DA1800, STR-DN1030)
Port 50001 (STR-DN1060)
Port 33336 (DN-1070 & CISv2)
Port 33335 (All Others)

Volume, Mute, Power, Input

SimpleControl also offers the suggestion that maybe connecting with the vendor supplied app is necessary before controlling the device, but there doesn’t seem to be one from Sony.

Well it’s now 2:15 am here on the west coast and I’ve been trying to get simple control to be able to control my Sony STR-ZA810ES since I woke up this morning at 8. I finally succeeded. Here’s the secret sauce.

I finally found an IOS app Named Video & TV SideView. Using this app I was able to “register” my ios device with the 810ES such that it now shows up in the Network Settings -> Home Network Access Control list with my iphone’s mac address as “allowed”. It also shows up in the “registered devices” list. It seems that Sony support’s contention that no remote registration or authentication is necessary is erroneous.

Once the device was registered, in Simple Control, I was able to add the 810ES as a manual IP device, using the DN-1070 zone one device type and it works… mostly. I don’t see all of the receiver modes that this particular model supports, and I find it a bit annoying that the inputs use the default names rather than the better, user supplied nicknames. It also shows you all your inputs, even ones that you’ve “hidden” from the sony interface.

Welp, that only took 18 hours to work out. If the Video & TV SideView app can work out discovery and registration with sony devices, why can’t Simple Control?

You are using an unsupported device. You got it working. That’s great. The list of devices we list as supported is not “every device possible to support”. It also means devices we do not list often can work completely or partially.

I would also note that contacting our support is likely to have been a far less time consuming method to come to the same conclusion as we have far more experience getting devices working even for things we don’t officially support.

Yes, I now understand that this is an “unsupported” device.I thought that the STR-DN810ES and STR-ZA810ES were either similar or exactly the same.