Sony XBR-75X900F Antenna Command

Sony is making it difficult to access Antenna within the Roomie Remote app. I’ve done some homework, even shifted through JSON, and I’m not getting this to work. Here’s the steps I took:
• Checked to see if Cable/Antenna access was an app through:
curl -v -XPOST -H 'X-Auth-PSK:1111' -d '{"method":"getApplicationList","params":[""],"id":4,"version":"1.0"}'. Nothing turned up – in the UI the Cable/Antenna appears as an app, so I was hoping it was treated as an app, but no luck.
• Tried adding command .key string but there’s not option to add in a value
• Tried adding command .key string end with AAAAAQAAAAEAAAAqAw== (found the key string on a reddit post)
• Read what Key String means in the DDR PDF, and I think that I’m getting the different uses of the term key confused between Roomie Remote and Sony.

I know very little about coding, so other than editing the .plist file (per the DDR ), does anyone have a suggestion of how I could tackle this? We honestly watch such little TV, it’s not a biggie to pull out the remote, but I want to maximize the value I’m getting out of this app. After all, this app is the reason I’m abandoning my Harmony Hub system.


Not really sure what you’re trying to do, but a similar command would look like this. Your cookie must match the device so it’s unlikely you can just supplement this command with another unless you use a static cookie, or override the entire internal device.

			<key>INPUT TV</key>
			<string>POST /sony/avContent
Content-Type: application/json
Cookie: $COOKIE$


I’m trying to setup an activity labeled “OTA” (there are a few rare times when I want to watch network TV). Currently, on the Bravia, the only way I can change to the Antenna is to go to the Bravia dashboard which is an Android interface. On the Bravia remote there is no way input to the Antenna without having to go to the dashboard. :man_shrugging: