TiVo "Channel Change Blocked"

That sounds like something to do with a specific channel. Do you have this regardless of the channel you’re trying to tune or perhaps with only some channels?

I happens consistently with about 6 or 7 specific channels out of the 165 I have selected for the guide.

The TiVo is for some reason rejecting those specific channel numbers. What’s unique about those channel numbers? Are they in the list of channels your TiVo accepts? It’s possible the guide is using a different numbering or fractional channel numbers for instance.

The problem channels seem to be in the 830 - 860 range. For example, the guide shows:

851 HBO

If I manually type 851 (enter) on Roomie’s virtual remote, it changes to channel 851 with no problem. But when I touch 851 on the guide, I get the error.


Perhaps a problem with the underlying guide data. What zip code and provider are you using?

97007, Beaverton - Comcast

Does the guide contain hidden data which is sent to the device rather than just the channel number which is displayed?

We replicated that behavior by turning off the channel on the TiVo side. The TiVo channel list must contain the channel in order to tune it. That’s set in Settings->Channels->Channel List.

I can verify this is the issue as well because I ran into this with my Premiere. If you tube to a channel that does not have a check mark next to it in the TiVo channel guide under channel options.

That worked perfectly! Thanks so much.