Triggers & HomeKit

I have setup a few scenes like “Watch Apple TV” that darken the room and set one of my Hue Strips to a specific brightness like 11%.

I then setup a trigger to look for that and start an Activity that turns on the projector, receiver, etc.

I changed the scene, the Hue strip changed to the correct brightness. But, the activity didn’t fire. I was playing around for about 10 minutes, trying different HomeKit tech (same thing on Insteon dimmers). Went back to the Hue and poof - it started working!

For about 20 min, and then it stopped. Deleted and recreated the activity and started working again. Today I come home and try it again and it didn’t work, and now I can’t get it to work.

I have the Simple Control TV hub running on a dedicated Apple TV, app is connected to it just fine. I have these activities set to run on Hub as well.

Not sure what to do or what I am missing. Was amazing to say “Hey Siri, watch AppleTV” to my HomePod and everything happened.

Btw - would it be possible for the hub to just detect a scene change rather than a Light? Would be nice not to pick a specific brightness. Not sure if that is possible with HomeKit.

Hey Ryan,

I’m a bit late, you may have solved the problem already. Anyway, I just tried the same thing. It worked a charm!

I could not get it to work reliably until I “reset” the trigger, so set the brightness to, say 2% as the first thing in any activity the trigger activates.

I second your suggestion for more integration.


OMG. This worked. You are a genius. Thank you!

You’re very welcome, I just had to try your idea, so I’m thanking you. Very nice way to get Siri to do things she can’t figure out for herself.

Fair play this is awesome thank you both. Set this up to use with Amazon Echo dots and routines set up in the Alexa app. It works perfectly!

As we don’t have the SC smart skill for Alexa yet (in the UK) this is a brilliant work around. I can control absolutely any device or function in SC with this ‘virtual’ smart skill.

If you try to use this idea, please note that if it suddenly stops working, even if you “reset” the trigger, it is because of a bug in the initialisation code of the trigger mechanism. This bug shows up if you reset or otherwise tamper with the Hub. The cure is to delete just one of the triggers and restore it to force the initialisation code to run correctly.

I’ve had this problem numerous times (5) but the cure always works.

Hopefully this will be fixed in 5.5, or maybe we will get proper “deep” integration with HomeKIt and Siri. At a minimum it would be nice to have virtual devices/variables in the Simple Hub that HomeKit can interact with.