Ubiquiti Protect RTSP

Has anybody figured out how to get the new Ubiquiti Profect RTSP working with Roomie? I had the last server-based version working, but for some reason I can’t get this new hardware version working…

I’m kind of baffled here. Ubiquiti gives the address: rtsp://

That address works in VLC on my computer and in the generic camera app IPCams on iOS. That means it’s something in Roomie that I’m not figuring out. I add a Ubiquiti camera, IP:, Port: 7447. In the advanced settings field RTSP Path I’ve tried PYZYYymAHxUbw5Cj, /PYZYYymAHxUbw5Cj, and the whole address, but none work.

Any thoughts?

Try turning off Hardware Acceleration.

Though 7447 is a highly non-standard port, so could imply some weirdness with that unit.

1 Like

Hardware acceleration off does not help. Is there a Roomie debugging mode so I can get a better idea of what’s going on behind the scenes?

The camera has no authentication? Why does that URL work in VLC as that would imply there is no username/password which would be very unusual.

Correct, if I paste just that URL in VLC on windows and IPCams on iOS, it gives me video and sound.

I tried it with and without authentication in Roomie, neither way seems to work.

Ubiquiti camera are very proprietary with a lot of vendor lock-in machinations built into their products. Really like their WAPs, but skipped their cameras and other networking components.

After googling around, it seems there is authentication when you use the cameras in standby mode, but none when using them through the NVR. Is Roomie assuming that authentication will be there?

I put one of my cameras in standalone mode to test RTSP without the NVR. It gives a standard 554 port and also allows authentication. Unfortunately, it worked in VLV and the iOS IPcam app, but again I could not get it to work with Roomie. Maybe I’m missing something in the Roomie configuration?

The protect NVR works fine for me with roomie. Use the IP for the protect controller, set port 7447 and set /PYZYYymAHxUbw5Cj (using your example) as the path in advanced settings. Looks like you tried that so it may be something else. No user name and password required, hardware decoding on.

Reviving an old thread. Has anyone been able to get this to work? I am trying to integrate my cameras from a Ubiquiti Dream Machine Pro and am experiencing the same thing as the original poster. I can see the camera though in VLC.

Stumbled across this thread trying to get mine working. Got my G4 doorbell with UDM-P working. Enable RTSP in the protect panel. Use IP of UDM-P, port 7447, path after / in advanced settings, no user or password and different from these directions that worked on my UDM-P is to disable acceleration.

To add to @jroberts622 post, I was able to get this working by using the IP address of the Unifi Protect server, not the individual camera. The RTSP path can be found in the Unifi Protect web UI in the camera’s settings under “Advanced” and you need to copy and paste the portion after the IP address into the RTSP path section in the Roomie Remote app. Use port 7447 and despite the previous post, I did have to enter my username and password for the Unifi Protect UI.