Updating device library on first run - never completes

Am having the same issue on my iPhone 4 (5.0.1), I guess due to the slow internet connections I have here. Tried closing the app and restarting it, it’s the same issue. Deleted it and now installing it again. Let’s see. Will keep you posted.

Had this same exact issue and posted on it here (see “IR device “Choose Type” window non responsive” ) What finally worked for me was to go to the compatibality tab when your logged into roomie. Theres a little white square at the top of that window that seems to “pulse”. I tapped that and a few seconds later… the download worked. Now Im trying to get the in app cable guide to interface with the remote. I can view it, but doesnt seem to be interactive with the cable box remote

Just for those casually reading this thread, this issue was addressed in the other thread. It’s due to poor network connections and generally resolves itself in minutes/hours. Restarting Roomie or your iOS device and checking your WiFi connection and router connection are the best methods to make sure the device library download completes successfully. It’s not related to anything else you might be doing in Roomie, it’s just network connectivity. Amazon and Apple have been aware of these issues that sometimes cause delays with bad network connections for many months now (actually much longer), but still no resolution.

We will likely adopt a slightly different method for distributing library updates in a future release to work around it for those still experiencing it.

Thanks jaydebeers and support staff for the heads up. Appreciate this.

Hi, I DID get this to work no problems with an iphone 4 (same network - 25mbps down/10 mbps up). The ipod just sits and spins at startup on the “Updating device library” - cant get past that to do any settings/changes. I deleted the app, restarted the ios device, reinstalled - several times to same effect. If there is any way to do some debugging on this - would appreciate it. thanks.

Same issue as jegan. Works fine on ipad3, iphone4. But hangs on installing on new iphone5. Progress bar fills up completely and after that it just hangs (now more than an hour). Multiple times uninstall, reinstall. same problem. I cannot stop the program either because in this stage it’s not even shown in the “task manager”. My internet is working fine though… some assistance would be nice… Arnoud

If the issue is caused by a network routing issue between you and Amazon (where our servers are run), then there is nothing you can do until it resolves itself which would likely be fairly rapidly as that would imply a fairly major routing issue. The same tips from the prior post in this thread still apply. We’ve never seen or heard of this lasting more than a day or so and is related either to your device’s network connectivity or your local site experiencing a routing issue.

Hi thanks for the fast reply. Unfortunately i think it’s really the iphone 5.

The reason being:

uninstalled roomie on iphone 4 and reinstalled. Updating device library succeeds. Wifi netwok and amazon servers must be ok then.
right after that uninstalled roomie on iphone5, restarted the phone and reinstalled roomie. Updating device library hangs again.
both run iOS 6.0.1 but iphone4 (10A523) and iphone5 (10A525).
both are connected to the same itunes account
both use the same wifi account
iphone5 still has more than 40gigs of free space.

So do you have any more suggestions?
oh, and the ipad3 has also IOS 6.0.1 (10A523). Works fine. So i’m pretty sure it must be the 6.0.1 (10A525) on the iphone that causes the problem.

It’s not the iPhone 5 as of course a huge portion of the user base uses that without issue. One other thing to try as it’s an iPhone is switching your active network. If you’re using Wi-Fi, turn off Wi-Fi and try again. If not, turn on Wi-Fi using local Internet.

You can restart the process by simply restarting Roomie (tap Home for Home screen, double tap Home the bring up app bar, then hold-tap Roomie).

OK, restarting roomie works. I double tapped on the home button when roomie hanged. in that case it’s not shown in the list of active programs (strange…). Going to the home screen first and then double tapping shows roomie. Then i can stop it. At least i don’t have to reinstall it every time now. A much better interface would being able to tap the “update device library” screen to cancel the update.

Back to the real issue: updating device lib over WIFI.
I now uninstall roomie on both iPhone4 and 5 simultaneously and install on both. both start to download the device lib. but iphone 4 MANY times faster. Both connected to the same wifi (airport extreme). Iphone 4 succeeds iphone5 hangs again. Only difference is that iphone5 has a sim, iphone 4 not.

removed sim from iphone5 AND connected iphone5 to my wireless thomson router. It downloads very slowly but after a long time it does work!

Now i want to get to the bottom of this…

Trying again with iphone5 without sim on airport extreme network. Fails.

Trying again with iphone5 with thomson router and sim but mobile network data disabled. (wifi should have preference above mobile data anyway but you never know these days…) Fails.

Trying again with thomson router and sim but mobile network data disabled AND 3g network off (which shouldn’t make a difference anyway… like before wifi should have preference above mobile data but you never know these days…) Fails.

Trying again with thomson router without sim. Fail again! But this has worked 1 time… WTF!

Ok back to iphone4 to make sure my network is ok. Reinstall Roomie and try again. Fast download and NO problem on both routers!

Furthermore installing the update over cellular (with disabled wifi): No problem!

Now tell me again this is not iphone5-wifi related… :slight_smile:

Jus curious, are you using some level of encryption for sending the device updates? Like AES encoded data? There seem to be iPhone 5’s with wifi problems in combination with data encryption. I might have one of those…

I wonder what kind of ipod jegan has. maybe last generation like iphone5 with new (failing) networking hardware?

i let you know if i find something later. Now i have to get some fresh air :slight_smile:

NB So the conclusion is i have NO problems updating WITHOUT wifi, but only with wifi on 2 different routers and only with my iphone 5 and only with some specific data… normal browsing goes fine.