Using Shortcuts with "Show When Run" Disabled

I am using the Shortcuts app to set up some automations with Roomie. One example is double-tapping the back of the phone to pause the current activity. This works very well!

However, when I do this I get a notification that I have to dismiss (see below).

Is there a way to run this shortcut without showing this notification banner?

If I disable the “Show When Run” toggle in the shortcut setup screen below, the notification banner won’t show but Roomie Remote will not execute the action.


Is there a way for Shortcuts that work with Roomie Remote to run without that notification banner?