Cannot Control an Epson 3800 Projector

Anyone have any success controlling an Epson 3800 4K projector? I tried the recommended port 4352, using both the “All Projectors” and the “pjtalk” options. No joy. Notwithstanding the recommendation, the projector has five (5) open ports:

  • 80
  • 3620 (ep-pcp) aka “Epson projector control”
  • 3621 (ep-nsp) aka “Epson network screen port”
  • 3629 (escvpnet), and
  • 5357 (wsdapi) “Web services for devices API”

I tried all of these, using both options, to no effect. However I DID prove the projector is controllable over TCP/IP, using Epson’s own Projector Control app on the iPhone.


1 Like

Again, as noted in the stickies all over the forum, it is very unlikely that the right path here is posting to the forum. Meanwhile, this kind of thing is trivial to resolve via support ticket.

Glancing at the Epson page, I don’t even see an Ethernet port on the spec list:

What is the network interface you’re trying to use? If you hadn’t port-scanned it, the spec page makes it sound like a serial-only model. Serial is probably going to be the best control method for that unit anyway.

You’ve gotten people gun shy over the years by consistently jumping on them for posting or reporting in the wrong place. I’ve developed a simple algorithm, which I certainly can revise: If it appears that your software is screwing up, I’ll put in a support request via the app. If it appears that it is something that I don’t understand, I’ll ask fellow users first. Finally, if there is a specific sticky post that exhaustively lists what types of issues should be raised where, I’d happily receive a pointer to it.

Now, to advance the conversation: The Epson 3800, which I bought to use while I am waiting for my JVC DLA-NZ8, has a WiFi dongle accessory from Epson, specifically for their projectors that don’t have RJ-45 Ethernet ports. The firmware/menus on the projector have an entire section to set up this as the TCP/IP interface to the projector. I set this dongle up easily, and did a port scan when the recommended port in your compatibility list didn’t work.

Although the main focus of this projector’s WiFi interface is for users to directly stream content to the projector from PC’s or handheld devices (there is an app for that), it also specifically says in the datasheet and the documentation that the interface can be used for control, as well. My post reported my failed attempts to take control, notwithstanding Epson’s statements, except with Epson’s own iOS app.

Finally, I concluded that one of the reasons that Roomie did not accommodate this fairly recent projector is that you had never seen it. I also assumed that if your interest were piqued, you’d follow up. However, to keep my interface attempts moving along, I immediately purchased for 2nd-day delivery a Global Cache iTach Ethernet to RS232 interface, since the only conceivable purpose of this ancient technology on a modern device was for legacy control systems. I received the iTach device yesterday.

Last night, I successfully trained Roomie and the IP-to-serial Global Cache serial interface to fully control this projector, using the serial and “All Models” options in Roomie. Because of your outstandingly well thought out software design, it was an effortless process, and I have full control via RS232.

So, I no longer have a pressing need to discover why this model resisted IP control. Just a curiosity remains. I’ll gladly expose the projector on the Internet, if you want to poke at it, or try out any code you might gen up. Just let me know by PM. Otherwise, I’m a happy camper.

Thanks for the fast response.