Has anybody managed to get lightwaverf to work since they added support i am struggling any help appreciated

I have. Struggled at first and couldn’t get the default remote to work at all.

I added the wifi link manually on port 9760, deleted the buttons from the remote and added new buttons. There are two parameters for the command - the first is the room number and the second the device number. For my living room lights it was 1 and 1.

Also the first time you use your iPhone etc a message will show link the wifi link to register the device - just press a button to register and all should be good.



Did you put both numbers in parameter 1 and did you have to put a space between them quite new to all this so still learning.

Have got it showing up on the display of the wifi link but now switching the lights on



Parameter One was 1 and Parameter Two was 1. Didn’t need anything else. I actually have two lights in the living room so the second was was Parameter One 1 (for the room) and Parameter Two 2 (for the device in that room).

Hope that makes sense.

Yes understand but not working with me have submitted a support ticket see what they say does show the command on the wififlink box so will have to keep trying

Have you used the lightwaverf app to setup the rooms and devices?

Got it working but to swtich on i have have to use mood 5 have tried the light on but does not work so getting there slowly, yes i have used the lightwave app to setup the rooms

I have got it working tonight with all my lightwave light switches but the relay on the bathroom lights does not with roomie so far and my main concern is the on/off plugs I cannot seem to get to work?


there is no option for on or off and the light on does not communicate with the plugs?

Hi ks055


I had the same problem i used the Mood5 to switch on my plugs and it seems to work i have emailed support about this

Steveing thanks for the heads up, I will give that a try this week and let you know.

Steveing the mood5 only has a room parameter (1) therefore you cannot select the device… I cant understand how you got it to turn your plus on and off?

Hi Steving, they have come back asking for the actual commands for on off? The list I have does not have on off on it apart from lights

The new .DEVICE ON and .DEVICE OFF commands are now live in the latest library update to enable usage of non-lighting devices. Their parameters are Room Number and Device Number.

Thank you.

I really wanna setup my lighit wave rf with roomie but am so lost its unbelieveabl, I’ve red the psts here but still lost, will appreciate any assistance :frowning: Thanks. Ps I’ve just acquired my lightwave rf modules and wifi link setup up iPhone app and moods so only need to setup roomie on ipad, where do I begin?

Hi Darkgroova


Have you managed to get it working if not what is the exact problem i am no expert but have got it working so may be able to help

@Steveing i haven’t yet could you be an angel and help me please


i have 5 rooms setup as follow, each room has 6 devices

room 1 is Landin

2 is bedroom

3 is kitchen

4 is living room

5 is looft

each room will also have the 3 different moods

i thought to create a room in roomie call it automation and add the various rooms lightwave rf rooms as individual remote controls, is this even possible? can it be done?

HI Darkg


Not sure if that can be done have you tried if so what was the problem , i have my roomie set up on a room by room so say living room. In this i have two lightwave rf sockets and one plug. So first i added the device which is lightwave wifi link this is done by manualy adding ip adr then using port 9760.

I then added an activity say lamps it opens remote which is lightwaverf i then add remote design i choose a new design then i choose add button now then the command for the plug its .DEVICE ON then Parameter 1 is the room Parameter2 is the device. you need to now how the rooms are set up on your lightwaverf setup so in my case when i open the lightwave rf app the first rooom is livingroom so i would put 1 in parameter 1 when i click on the lightwaverf app on livingroom it takes you to next screen this shows the devices you have set up in my case i have lamp and tv so if i wanted to switch the lamp on i would put 1 in parameter2 box or 2 if i wanted to switch the tv on.

Hope this makes sense is try it and see come back if you require help or submit a ticket to roomie support have found them to be very helpful

@Steveing, thanks man, all working great,

Hi there amazing people, quick question , I’ve noticed in lightwave rf roomie remote design settings there are now 3 parameter rows 1st = room, 2nd = device, 3 = ?, what’s the 3rd one for anyone?