Sony BDP-S590 Blu Ray Power On Problems

I’m having trouble with the power on function of the Sony S590 Blu Ray Player. I’ve read the other posts in this forum, and know about the requirement to register the device with the Sony Media Remote app, which I have done. I also have HDMI Control set to On and Quick Start set to On.

When I add the device, all functions appear to work properly except the Power On function. Does anyone have any suggestions about how to correct this?

I’m not sure if this has anything to do with it, but I’ve also noticed that the device does not appear in the Roomie’s device list unless the power to the player is set to On. (It’s as if there is no IP communication with the player unless the power is on.)

Any help is appreciated.

Also, the player does not show up in the list of devices when making an input selection (Input Switching) for my Denon 3808CI AVR. Yet it does appear in the main device selection list.

Again, any help is appreciated.

That sounds normal. Have you added the +WAKE ON LAN command per the FAQ?

Just sending POWER ON does not work for Wake on LAN devices.

Yes, WAKE ON LAN was set. However, I discovered that the MAC address filled in by auto discovery was incorrect. Not sure why. Once I entered the correct MAC address, all was fine.

Thanks for your help!

sendme, how did you change the MAC address from the one provided autodiscovery? I’m having the same issue. But don’t seem able to change it.

I have full control over the device with the exception of wakeonlan.

The silly mediaremote works fine, but nothing happening in roomie.

I’m having the exact same issue. Have tried all the suggestions but don’t understand where to change the MAC address. If someone could elaborate it would be a great Christmas gift!



Try leaving the MAC address field blank.

It worked for me.

Cheers! And Merry Christmas!



Thanks for the suggestion HoppyBrewer. Where did you find the field? Did you add the device manually instead of auto discovery?

leave the auto discovery address.

the field I’m referring to is under the ‘wake-on-LAN’ command.

the last field in the command is for the MAC address. Leave it blank.



Thanks again HB! I’ll give it a shot when I get back home. And a Merry Christmas to you!

I’ve done the following but still cannot get roomie remote to wake the bdp-s790, although the sony media remote will wake he player over the wireless connection, so I know it can be done. I have full control ver the device except “wake on LAN” activated via Roomie Remote.

  1. registered the device with the Sony media remote app and verified the device is registered on the bdp-s790 under the “registered media remote devices” screen after performing the registration. Verified the the device can be powered up via the Sony media remote app. Verified that my ipad is registered in the settings: nickname within the Sony media remote app.

2). Set the “remote start” to “on” in network setting screen of the bdp-s790

3). Set the quick start mode on the bdp-s790 under system settings menu to “on”.

  1. set up the "wake on LAN"command in the Play Blu-Ray activity in Roomie Remote.

  2. tried leaving the MAC address in the roomie remote: Add command: “wake on lan” screen blank; no luck.

6). tried defining the MAC address in the Add Command: “wake on lan” screen as per the MAC address defined in the “network status info” screen under network settings menu on the bdp-s790; no luck.

7). tried setting the power for all activities in the device menu to yes; no luck.

8). Tried setting the “power device” in the activity menu to “Sony blu ray player” and have also set it to “none”. “Wake on command” was set in the start commands in both scenarios. No luck in either case.

I was thinking it might be my router, but Sony media remote app will power up over wireless lan, it’s just that roomie remote won’t, so it’s not router settings.

I’d prefer using the IP functionality instead of IR functionality, anyone have any ideas?

How is your 790 connected? There may be some cases here where the player is displaying and handing out one MAC whereas it’s actually listening on the other MAC (the Wi-Fi and Ethernet MAC are not the same).

It’s connected via wifi.

That’s probably it. The player may be telling you the Ethernet MAC. Either connect it via Ethernet or enter the Wi-Fi MAC into Roomie.

i went to my router and looked up the MAC address in the DHCP client table. Verified the IP address was the same as the network status info on the 790. Entered the MAC address as per the table In the Wake on LAN command MAC addrfile field. Still no luck.

The MAC address in the router local network dhcp client table was different than the MAC address in the 790"s network status.

Let’s move this to support so we can get diagnostics. Please use these steps:

  1. Turn on Collect Diagnostics.
  2. Perform an operation in Roomie that would send the Wake on LAN command to your player.
    [Verify that it didn’t work.]
  3. Turn on the 790 manually.
  4. Tap Add Device in Roomie. Wait about 20 seconds.
  5. Tap Send Diagnostics and then turn off Collect Diagnostics.
  6. Email with the time of submission.

Seems that using a wired set up and not defining the MAC address in the add command: wake on LAN screen did the trick. Luckily I had the option , but I was planning to use the wire for something else. Any ideas why the wireless method won’t work?

Okay, I’ll try the steps tomorrow, gotta get to sleep, have to go to work soon. Thanks for your help. I’ll be in touch.

I am having the same issues. Is roomie looking into the wifi sony issue?